Раздел: Название

  • Название
След →

Пакет SIMP Light

Руководство пользователя
2014
simp@miniscada.com
http://miniscada.com/allproducts/simp-light


Раздел: Введение

  • Введение
← Пред
След →

Введение

  • SIMP Light — это интегрированный пакет поддержки АСУТП, предназначенный для визуального представления, моделирования и мониторинга физических и виртуальных устройств, подключенных к компьютеру с целью обеспечения автоматизации или эмуляции технологических процессов.
  • SIMP Light предоставляет удобный интерфейс для непрерывного сбора первичной информации от устройств нижнего уровня, а также сохраняет данные в форматах, удобных для математической обработки.
  • SIMP Light позволяет разрабатывать и редактировать мнемосхемы устройств нижнего уровня любой сложности, а также автоматизировать ведение мониторинга аварий и контроля квитирования (выхода значения за установленные пределы) в технологических процессах.
  • Основными преимуществами пакета SIMP Light являются простота настроек, удобство использования и интуитивно понятный интерфейс.
Пакет SIMP Light состоит из нескольких взаимодополняющих функциональных модулей:
  • Редактор каналов
  • Монитор
  • Редактор мнемосхем
  • Модуль просмотра графиков
  • Менеджер проектов


Раздел: Редактор каналов SIMP Light

  • Редактор каналов SIMP Light
← Пред
След →

Редактор каналов SIMP Light

Редактор каналов SIMP Light предназначен для конфигурации свойств каналов (устройств нижнего уровня), ОРС серверов и пользовательских настроек пакета. Наиболее существенными чертами Редактора каналов являются:
  • Гибкая настройка режима видимости ОРС серверов, каналов и их состояний
  • Предоставление исчерпывающей информации о значениях, свойствах и ограничениях каналов
  • Возможность определения виртуальных каналов, эмулирующих работу устройства нижнего уровня при помощи запрограммированного скрипта
  • Широкий спектр настроек пакета, включающий возможность просмотра информации через веб-интерфейс и обеспечение ограничения доступа

Содержание раздела Редактор каналов SIMP Light

Обзор функциональности модуля
Работа с ОРС серверами
Работа с каналами
Работа с проектами
Настройки редактора каналов


Раздел: Обзор функциональности модуля

  • Редактор каналов SIMP Light
  • Обзор функциональности модуля
← Пред
След →

Обзор функциональности модуля

Р едактор каналов предназначен для работы с ОРС серверами, каналами, пользовательскими проектами, а также с общими настройками использования SIMP Light.
1. Работа с ОРС серверами
Редактор каналов отображает список имеющихся ОРС серверов, устройств нижнего уровня, называемых каналами или тегами, а также приборов или групп каналов. Пользователь может выбрать режим видимости серверов и каналов, добавлять или удалять каналы на рабочем сервере, а также менять активность канала, то есть его наличие в процессе мониторинга и сбора данных. Бесплатная версия SIMP Light обладает ограничениями по количеству отображаемых серверов и каналов.
2. Работа с каналами
Наиболее важная часть функциональности Редактора каналов — это заполнение так называемого паспорта канала, в рамках которого задаются:
  • допустимая нижняя и верхняя граница значения канала (квитируемое значение)
  • тип переменной, читаемой из канала
  • режим отображения в программе мониторинга текущего состояния
  • наименование канала и т.д.
Редактор каналов поддерживает два типа каналов: физический (для реальных устройств нижнего уровня) и виртуальный (для моделирования технологических процессов). Значением виртуального канала можно манипулировать с помощью программируемого скрипта, который определяет процедуру вычисления значения канала.
3. Работа с проектами
Редактор каналов позволяет сохранить все изменения в профиле проекта, а также обеспечивает быстрое переключение между модулями для изменения и просмотра информации о текущем проекте.
4. Настройки редактора каналов
Редактор каналов служит для настройки общих свойств пакета SIMP Light, таких как:
  • настройки доступа
  • настройки оповещений
  • настройки автосохранения и синхронной записи в канал
  • настройки печати
Наиболее важной частью функциональности в этом разделе является возможность установления пароля для ограничения несанкционированного доступа к приложениям SIMP Light.


Раздел: Работа с ОРС серверами

  • Редактор каналов SIMP Light
  • Работа с ОРС серверами
← Пред
След →

Работа с ОРС серверами

ОРС сервер — это программное обеспечение, предназначенное для сбора, передачи и синхронизации информации о внешних устройствах нижнего уровня, подключенных к компьютеру, таких как программируемые логические контроллеры и распределенные системы управления. После запуска ОРС сервер непрерывно считывает данные о состоянии устройства. Единицей считанных данных является текущее значение канала или тега. Данные различных типов записываются в различные каналы или теги на сервере. Каналы могут быть объединены в группы, называемые приборами.
Редактор каналов SIMP Light обеспечивает подключение и сбор данных с доступных ОРС серверов. Кроме того, Редактор каналов предоставляет пользователю возможность работы с сервером виртуальных каналов, имитирующих работу физических с помощью настраиваемых скриптов и математических формул.

Содержание раздела Работа с ОРС серверами

Просмотр списка ОРС серверов
Редактирование списка ОРС серверов
Переименование сервера
Переименование группы каналов на сервере


Раздел: Просмотр списка ОРС серверов

  • Редактор каналов SIMP Light
  • Работа с ОРС серверами
  • Просмотр списка ОРС серверов
← Пред
След →

Просмотр списка ОРС серверов

Левая панель Редактора каналов SIMP Light (Источник) служит для просмотра списка активных ОРС серверов, запущенных на вашем компьютере:
Просмотр списка ОРС серверов

Список ОРС серверов

Данный список отображает все доступные сервера, их каналы и группы (приборы). Источник также отображает отличия в режиме видимости каналов.

Содержание раздела Просмотр списка ОРС серверов

Типы серверов
Приборы и теги
Режим просмотра


Раздел: Типы серверов

  • Редактор каналов SIMP Light
  • Работа с ОРС серверами
  • Просмотр списка ОРС серверов
  • Типы серверов
← Пред
След →

Типы серверов

Доступные сервера могут быть двух типов:

Активный ОРС сервер

1. Активный ОРС сервер
Установленный и запущенный OPC DA сервер. Считывает данные с устройства нижнего уровня, записываемые в физические каналы. Бесплатная версия SIMP Light может подключаться только к локальным серверам.

Виртуальный сервер

2. Виртуальный сервер
Внутренний сервер, предназначенный для создания виртуальных каналов. Данный сервер служит для эмуляции технологических процессов. Все каналы на этом сервере виртуальные, то есть работают в режиме моделирования процесса с помощью программируемого скрипта.


Раздел: Приборы и теги

  • Редактор каналов SIMP Light
  • Работа с ОРС серверами
  • Просмотр списка ОРС серверов
  • Приборы и теги
← Пред
След →

Приборы и теги

Любой ОРС сервер в списке обладает набором каналов (тегов) и приборов (групп каналов), предназначенных для считывания информации об устройстве. Их можно просмотреть, развернув текущий сервер с помощью щелчка левой кнопкой мыши:
Приборы и теги

Прибор

Каналы на сервере объединяются в группы (приборы). Развернув прибор, можно просмотреть все относящиеся к нему каналы.

Активный канал

2. Активный канал
Данная иконка означает, что текущий канал является активным, то есть его данные считываются в программе мониторинга и контроля SIMP Light.

Неактивный канал

3. Неактивный канал
Данная иконка означает, что информация из этого канала не отображается в программе мониторинга и контроля SIMP Light.


Раздел: Режим просмотра

  • Редактор каналов SIMP Light
  • Работа с ОРС серверами
  • Просмотр списка ОРС серверов
  • Режим просмотра
← Пред
След →

Режим просмотра

В контекстном меню левой панели можно выбрать режим просмотра списка серверов. Нажмите на правую кнопку мыши:

Выбор режима просмотра

1. Выбор режима просмотра
Развернуть или свернуть все приборы и теги на всех серверах одновременно можно одним щелчком мыши на соответствующем пункте меню.


Раздел: Редактирование списка ОРС серверов

  • Редактор каналов SIMP Light
  • Работа с ОРС серверами
  • Редактирование списка ОРС серверов
← Пред
След →

Редактирование списка ОРС серверов

Редактор каналов SIMP Light предоставляет пользователю возможность настроить вид списка ОРС серверов в панели Источник. Для выбора отображаемых серверов перейдите к пункту Список ОРС серверов в меню Настройки:
Данная команда открывает диалоговое окно настройки видимости ОРС серверов:
Редактирование списка ОРС серверов

Флаг видимости сервера

1. Флаг видимости сервера
Установите данный флаг, для того чтобы сервер отображался в панели Источник. Изменения будут действительны после перезапуска Редактора каналов.


Раздел: Переименование сервера

  • Редактор каналов SIMP Light
  • Работа с ОРС серверами
  • Переименование сервера
← Пред
След →

Переименование сервера

Выберите пункт Редактор имени сервера из контекстного меню текущего ОРС сервера (вызывается по нажатию правой кнопки мыши):
Данная команда вызывает диалоговое окно редактора имени сервера:
Укажите новое имя и нажмите Ок.


Раздел: Переименование группы каналов на сервере

  • Редактор каналов SIMP Light
  • Работа с ОРС серверами
  • Переименование группы каналов на сервере
← Пред
След →

Переименование группы каналов на сервере

Разверните текущий сервер и выберите прибор. Выберите пункт Редактор имени прибора из контекстного меню (вызывается по нажатию правой кнопки мыши):
Данная команда вызывает диалоговое окно редактора имени сервера:
Введите новое имя и нажмите Ок.


Раздел: Работа с каналами

  • Редактор каналов SIMP Light
  • Работа с каналами
← Пред
След →

Работа с каналами

Канал — это поток данных ОРС сервера, считанный с устройства нижнего уровня. Вся информация о состоянии устройств, подключенных к ОРС серверу, непрерывно преобразуется в цифровой вид и записывается в каналы. Пакет SIMP Light распознает данные каналов сервера и предоставляет пользователю возможность их просмотреть, сохранить и преобразовать их в графический формат.
Редактор каналов позволяет пользователю управлять рабочими или активными каналами и настроить процесс чтения информации из каналов. Так, например, предоставляется возможность манипулировать временными интервалами и условиями чтения данных из канала, а также контрольными граничными значениями, о достижении которых монитор автоматически извещает диспетчера системы. Пользователь может настроить шаблон математической формулы, с помощью которой данные преобразуются и сохраняются.
Редактор каналов распознает данные двух типов — аналоговые (численное или строковое значение) и логические (булево значение). Помимо этого, Редактор каналов поддерживает создание внутренних виртуальных каналов. Виртуальные каналы обслуживаются программируемым скриптом. Они могут использоваться для качественной проверки логики мнемосхемы системы управления и моделирования работы реального технологического процесса.

Содержание раздела Работа с каналами

Просмотр списка каналов
Добавление и удаление виртуальных каналов
Редактирование профилей каналов
Запуск теста ОРС каналов
Копирование свойств каналов


Раздел: Просмотр списка каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Просмотр списка каналов
← Пред
След →

Просмотр списка каналов

Главное окно Редактора каналов служит для отображения каналов ОРС сервера, выбранных пользователем активных каналов, а также свойств текущего активного канала:
Панель источника каналов служит для отображения полного списка каналов ОРС сервера. Отображаемые каналы могут быть двух типов:
  • аналоговые
  • логические
Кроме того, канал может находиться в одном их трех состояний:
  • неактивный
  • активный
  • выделенный
Просмотр списка каналов

Канал аналогового типа

1. Канал аналогового типа
Служит для считывания численных или строковых данных. Численные данные могут быть одного из нескольких стандартных типов: целочисленные, действительные, и проч. Иконка изображает синусоиду.

Канал логического типа

2. Канал логического типа
Служат для считывания дискретных данных, которые могут находиться лишь в одном из двух состояний: включено/выключено (0/1). Как правило, отображают состояние различных заглушек и переключателей на мнемосхеме. Иконка изображает зубчатую функцию.

Неактивный канал

3. Неактивный канал
Канал, который на данный момент не выбран пользователем для контроля и сохранения текущих данных. Этот канал не отображается в панели списка активных каналов, в Мониторе и Модуле просмотра графиков. Иконка изображает перечеркнутый круг.

Активный канал

4. Активный канал
Канал, который в настоящий момент отображается в панели списка активных каналов. Редактор каналов предоставляет доступ к настройкам активного канала. Состояние канала распознается и контролируется Монитором и Модулем просмотра графиков. Иконка изображает зеленую стрелку.

Выделенный канал

5. Выделенный канал
Активный канал, который в настоящий момент выделен в центральной панели. Его свойства отображаются в панели настроек канала. Иконка изображает красную стрелку.

Содержание раздела Просмотр списка каналов

Просмотр и изменение активности канала
Изменение порядка каналов
Фильтрация списка каналов


Раздел: Просмотр и изменение активности канала

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Просмотр списка каналов
  • Просмотр и изменение активности канала
← Пред
След →

Просмотр и изменение активности канала

Редактор каналов позволяет пользователю выбрать необходимые для работы каналы из числа всех имеющихся каналов на сервере. Выбранные рабочие каналы называются активными. Они отображаются в центральной панели Редактора каналов, Мониторе и Модуле просмотра графиков. Данные активного канала считываются в базу данных и служат для контроля состояния технологического процесса. Для того чтобы назначить канал активным, выделите любой неактивный канал в панели источника и перетащите его в список активных каналов.
После этого канал добавится к списку активных, а его настройки будут отображаться в панели свойств канала. Бесплатная версия SIMP Light имеет ограничение по числу активных каналов: их может быть не более, чем 8.
Панель активных каналов дополнительно отображает следующие свойства:
  • Видимость канала
  • Наличие скрипта виртуального канала
  • Запуск скрипта по таймеру
  • Запуск скрипта по событию записи
Просмотр и изменение активности канала

Невидимый канал

1. Невидимый канал
Канал активен, но находится вне видимости Монитора. Иконка невидимого канала окрашена в серый цвет.

Виртуальный канал без скрипта

2. Виртуальный канал без скрипта
Канал виртуальный, однако не использует скрипт. Как правило, это статический канал, переключатель, значение которого учитывается для формирования выходного значения другого канала. Подробнее здесь. Иконка изображает разорванную стрелку.

Виртуальный канал со скриптом, запускаемым по таймеру

3. Виртуальный канал со скриптом, запускаемым по таймеру
Канал виртуальный (иконка желтого цвета) и использует скрипт для формирования выходного значения. Подробнее здесь. Иконка отображает стрелку с часами.

Виртуальный канал со скриптом, запускаемым по записи

4. Виртуальный канал со скриптом, запускаемым по записи
Канал виртуальный (иконка желтого цвета) и использует скрипт для формирования выходного значения. Подробнее здесь. Иконка отображает стрелку с кнопкой запуска.

Физический канал

5. Физический канал
Видимый физический канал отображается стрелкой зеленого цвета.
Для того чтобы удалить канал из числа активных, выделите его в списке активных каналов и нажмите клавишу Del или снимите флаг Статус канала в панели свойств канала:


Раздел: Изменение порядка каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Просмотр списка каналов
  • Изменение порядка каналов
← Пред
След →

Изменение порядка каналов

Редактор каналов позволяет установить порядок отображения каналов в Мониторе и Модуле просмотра графиков. Используйте перетаскивание каналов в панели списка активных каналов для назначения определенного порядка:
Изменение порядка каналов

Сохранить изменения

1. Сохранить изменения
После нажатия кнопки Сохранить изменения будут действительны в других приложениях пакета SIMP Light.


Раздел: Фильтрация списка каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Просмотр списка каналов
  • Фильтрация списка каналов
← Пред
След →

Фильтрация списка каналов

Редактор каналов позволяет пользователю выбрать отображаемые каналы ОРС сервера в режиме фильтрации. Фильтрация скрывает служебные и редко используемые каналы, оставляя только необходимые — теги аналогового ввода, теги аналогового вывода, теги дискретного ввода, теги дискретного вывода. Помимо этого, режим фильтрации позволяет настроить конфигурацию на определённый ОРС сервер для типового использования в нескольких проектах. Для настройки фильтрации необходимо выполнить следующие шаги:
1. Выберите группу ОРС сервера и нажмите правую кнопку мыши. В раскрывшемся меню выберите Редактор видимости тегов:
2. Эта команда откроет окно редактирования видимости тегов:
Фильтрация списка каналов

Смена имени канала

1. Смена имени канала
Введите в поле новое имя для текущего канала.

Смена видимости канала

2. Смена видимости канала
Установите/снимите данный флаг для смены видимости канала.

Сохранение изменений

3. Сохранение изменений
Нажмите кнопку, для того чтобы сохранить изменения.

Отмена изменений

4. Отмена изменений
Нажмите кнопку для отмены всех новых изменений.

Контекстное меню редактора видимости тегов

5. Контекстное меню редактора видимости тегов
Контекстное меню (вызывается по нажатию правой кнопки мыши) позволяет включить или выключить все теги прибора одновременно.
В пакет SIMP Light включены автоматические фильтры на распространённые приборы от компании ОВЕН, поэтому на экран выводятся не все теги сервера. Режим редактирования параметров прибора позволяет сменить название тега и добавить тег в список.
Список параметров приборов от ОВЕН можно скачать на сайте http://www.owen.ru .


Раздел: Добавление и удаление виртуальных каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Добавление и удаление виртуальных каналов
← Пред
След →

Добавление и удаление виртуальных каналов

В отличие от физических каналов ОРС сервера, виртуальные каналы можно самостоятельно настраивать, добавлять и удалять. Для добавления нового или удаления уже существующего виртуального канала:
Добавление и удаление виртуальных каналов

Контекстное меню

1. Контекстное меню
Выберите соответствующий пункт в контекстном меню панели источника (вызывается по нажатию правой кнопки мыши). Команда удаления доступна только для выделенного в списке виртуального канала. Команда добавления доступна всегда.

Кнопки

Нажмите соответствующую кнопку в нижней части панели источника. Кнопка удаления доступна только для выделенного виртуального канала. Кнопка добавления доступна всегда.
После этого, новый виртуальный канал с именем Virtual сhannel # будет добавлен в конец списка внутренних каналов, или текущий выделенный виртуальный канал будет удален из списка. Для сохранения изменений нажмите кнопку Сохранить в панели списка активных каналов.


Раздел: Редактирование профилей каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
← Пред
След →

Редактирование профилей каналов

Основной функцией Редактора каналов является возможность настраивать свойства и режимы работы с активными каналами проекта. Так, например, пользователь может назначить формулы первичной обработки информации канала, видимость и имя канала, режим чтения информации из канала и сохранения в базу данных, установки контроля данных и оповещений. Профиль канала определяется в зависимости от его типа.

Содержание раздела Редактирование профилей каналов

Типы каналов
Общие настройки каналов
Настройки физических каналов
Настройки виртуальных каналов


Раздел: Типы каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Типы каналов
← Пред
След →

Типы каналов

Редактор каналов различает 4 основных типа каналов в зависимости от источника данных и типа данных.
1. Типы каналов по источнику данных.
Редактор каналов поддерживает два типа каналов по источнику данных:
  • Физический канал — является потоком данных о состоянии внешнего устройства, считанным с ОРС сервера.
  • Виртуальный канал — является оболочкой для программируемого скрипта и создается только для внутреннего использования в среде SIMP Light. С помощью виртуальных каналов удобно моделировать технологический процесс проекта и тестировать логические цепочки мнемосхем.
Помимо этого, виртуальные каналы могут быть трех типов, в зависимости от наличия и способа запуска скрипта:
  • Канал без скрипта
  • Канал со скриптом, запускаемым по таймеру
  • Канал со скриптом, запускаемым по событию записи
2. Типы каналов по типу данных
Редактор каналов автоматически распознает информацию, считанную с физических каналов по типу данных:
  • Аналоговый канал — содержит данные, относящиеся к
  1. целочисленному типу (ShortInt, SmallInt, Integer, Int64, Byte, Word, LongWord)
  2. действительному типу (Single, Double)
  3. дате и времени (Date, Time)
  4. другому типу (Unknown)
Для аналоговых каналов, как правило, в Редакторе каналов задаются граничные контрольные значения, о достижении которых программа мониторинга автоматически оповещает диспетчера.
  • Логический канал — содержит данные, относящиеся к типу Boolean, то есть это дискретный канал, который может принимать только два значения (0 и 1). Логический канал, как правило, используется для установки/снятия переключателя в мнемосхеме.
Пользователь может задавать и редактировать тип данных виртуального канала в панели свойств каналов. В случае физического канала, рекомендуется не менять тип распознаваемых данных в панели свойств, так как это может привести к ошибкам.
Свойства и настройки канала определяются его типом. Некоторые свойства являются общими для всех каналов, а некоторые специфическими только для данного типа каналов.


Раздел: Общие настройки каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Общие настройки каналов
← Пред
След →

Общие настройки каналов

К общим настройкам каналов относятся:
  • статус канала
  • интервал опроса
  • интервал сохранения в БД
  • наименование канала
  • сохранять в БД
  • видимость канала
  • тип переменной
  • задержка сигнала тревоги
Эти настройки действуют для всех имеющихся типов каналов:
Общие настройки каналов

Статус канала

1. Статус канала
Флаг включает/выключает активность канала. Активность канала определяет его наличие в процессе мониторинга и контроля данных. Текущие активные каналы можно просмотреть в центральной панели Редактора каналов. Подробнее здесь.

Интервал опроса

2. Интервал опроса
Определяет частоту, с которой текущее значение канала обновляется в процессе мониторинга данных (в миллисекундах).

Интервал сохранения в БД

3. Интервал сохранения в БД
Определяет частоту, с которой текущее значение канала сохраняется в базу данных пакета SIMP Light (в миллисекундах). По умолчанию, это значение совпадает со значением интервала опроса.

Наименование канала

4. Наименование канала
Имя канала, под которым текущий канал отображается в пакете SIMP Light. В случае удаления канала из списка активных, его имя также удаляется. Значение по умолчанию совпадает с названием канала на ОРС сервере. В случае виртуального канала, его имя используется в качестве переменной при обращении скрипта к значению канала.

Сохранять в БД

5. Сохранять в БД
Данный флаг определяет, необходимо ли сохранять считанную из канала информацию в базе данных SIMP Light.

Видимость канала

6. Видимость канала
Определяет, является ли канал видимым в Мониторе SIMP Light. Если значение виртуального канала необходимо лишь для внутреннего использования в текущем проекте, его видимость можно отключить.

Тип переменной

7. Тип переменной
Выпадающий список позволяет задать один из стандартных целочисленных или действительных типов, а также дату или время. Информация, считанная из канала, будет сохраняться в переменную выбранного типа.

Задержка сигнала тревоги

8. Задержка сигнала тревоги
Если при чтении данных из канала достигнуто заданное граничное значение, Монитор сигнализирует об аварийной ситуации. В этом поле можно задать временной интервал между моментом достижения границы и отправкой оповещения.
Внимание! Данное свойство отключено и не отображается для невидимого канала (флаг 6).

Содержание раздела Общие настройки каналов

Настройки аналоговых каналов
Настройки логических каналов
Настройки каналов типа Date и Time


Раздел: Настройки аналоговых каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Общие настройки каналов
  • Настройки аналоговых каналов
← Пред
След →

Настройки аналоговых каналов

Эти свойства можно устанавливать для всех каналов аналогового типа (физических и виртуальных):
  • Верх и низ шкалы
  • Верх и низ уставки
  • Измеряемая величина
  • Звук "верх уставки" и "низ уставки"
  • Формат данных (только для значений типа double и single)
Настройки аналоговых каналов

Верх и низ шкалы

1. Верх и низ шкалы
В этих полях задаются максимум и минимум инженерной шкалы, то есть границы в которых изменяется значение канала.

Верх и низ уставки

2. Верх и низ уставки
В этих полях задается допустимый максимум и минимум уставки значения канала. Данные свойства канала используются для контроля текущих измерений состояния устройства и определяют границы, при нарушении которых Монитор сигнализирует об аварийной ситуации.

Измеряемая величина

3. Измеряемая величина
Определяет, в каких величинах (проценты, градусы и т.д.) измеряется значение канала. Данное свойство служит для записи данных мониторинга в базу данных.

Звук "Верх уставки" и "Низ уставки"

4. Звук "Верх уставки" и "Низ уставки"
Если данные флаги установлены, то при достижении критического значения в текущем канале выдается звуковой сигнал.
Внимание! Для невидимого канала (флаг видимости канала отключен) данные свойства недействительны и не отображаются.

Формат переменной

5. Формат переменной
Это поле отображается в панели только для значений канала типа double и single. Оно позволяет задать формат отображения и сохранения действительной переменной, а именно зафиксировать число знаков после запятой.


Раздел: Настройки логических каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Общие настройки каналов
  • Настройки логических каналов
← Пред
След →

Настройки логических каналов

Настройки логических каналов включают в себя два специфических флага:
  • Контроль состояния "Вкл." — Монитор сигнализирует об установке значения канала в 1 и сохраняет его в журнал аварий.
  • Контроль состояния "Выкл." — Монитор сигнализирует об установке значения канала в 0 и сохраняет его в журнал аварий.
Эти флаги недоступны в режиме отключенной видимости канала.


Раздел: Настройки каналов типа Date и Time

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Общие настройки каналов
  • Настройки каналов типа Date и Time
← Пред
След →

Настройки каналов типа Date и Time

Для каналов типа Date и Time (дата и время) следующие общие настройки и настройки аналоговых каналов отсутствуют:
  • Интервал сохранения в БД
  • Сохранять в БД
  • Задержка сигнала тревоги
  • Верх и низ шкалы
  • Верх и низ уставки
  • Звук "верх уставки" и "низ уставки"
  • Формат данных
Настройки каналов типа Date и Time
Таким образом, дата и время, считанные из канала, не сохраняются и не используются для контроля значений.


Раздел: Настройки физических каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Настройки физических каналов
← Пред
След →

Настройки физических каналов

Физические каналы отображаются в панели источника, если на компьютере установлен и запущен ОРС сервер. Для того чтобы настроить физический канал, необходимо добавить его в список активных каналов и выделить. При этом в панели источника текущий выделенный канал будет отмечен красной стрелкой:
Свойства текущего активного физического канала отображаются в левой панели Редактора каналов. Помимо общих настроек, у физических каналов есть два специальных свойства:
Настройки физических каналов

Поле формулы аналогового канала

1. Поле формулы аналогового канала
В данном поле можно ввести формулу для первичной обработки данных, считанных из канала. Это свойство задается только для каналов аналогового типа. Подробнее о Редакторе формул можно прочитать здесь.

Контроль связи

2. Контроль связи
Если этот флаг выставлен, то система автоматически контролирует состояние канала. При отсутствии изменений в канале в течение 5 минут его состояние устанавливается в неактивное. На мнемосхеме это отображается заштриховкой компонента. Как правило, неактивное состояние канала является сигналом того, что возникли проблемы связи с ОРС сервером.
Внимание! Это флаг необходимо отключить для канала логического типа.

Содержание раздела Настройки физических каналов

Редактор формул


Раздел: Редактор формул

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Настройки физических каналов
  • Редактор формул
← Пред
След →

Редактор формул

Редактор формул служит для математической обработки данных физического канала. Формула, заданная в окне редактора, автоматически применяется к каждому считанному значению канала. Вычисленное значение отображается в Мониторе, Модуле просмотра графиков и может быть сохранено в базе данных проекта. Единственный тип канала, который поддерживает задание и вычисление формул, — это физический канал аналогового типа.
Для того чтобы запустить Редактор формул текущего физического канала, нажмите соответствующую кнопку в поле Формула в панели свойств канала:
После этого откроется диалоговое окно Редактора формул:

Поле редактирования формулы

1. Поле редактирования формулы
Формула для расчета значения канала вводится в данном поле. Переменная Val содержит исходное (считанное с ОРС сервера) значение канала. Вычисленное в формуле значение будет использоваться для контроля значений канала, а также сохраняться в базе данных пакета SIMP Light.
Поддерживаемые команды:
1) Простейшие арифметические операторы:
+ | сложение
- | вычитание
* | умножение
/ | деление
x ^ y | возведение x в степень y
x ! | факториал x
[ x ] | целая часть x
| x | | модуль x
( ... ) { ... } | скобки в выражениях
2) Тригонометрические функции:
sin | синус
cos | косинус
tan, tg | тангенс
cotan, ctg | котангенс
arcsin | арксинус
arccos | арккосинус
arctan, arctg | арктангенс
arccotan, arctg | арккотангенс
sinh, sh | синус гиперболический
cosh,ch | косинус гиперболический
tanh, th | тангенс гиперболический
cotanh, cth | котангенс гиперболический
arcsinh, arcsh | арксинус гиперболический
arccosh,arcch | арккосинус гиперболический
arctanh, arcth | арктангенс гиперболический
arccotanh, arccth | арккотангенс гиперболический
3) Алгебраические функции:
sqr (x) | возведение x в квадрат
sqrt (x) | вычисление квадратного корня x
ln (x) | логарифм x по основанию e
exp (x) | экспонента x
abs (x) | модуль x
trunc (x) | целая часть x
lg (x), log10 (x) | десятичный логарифм x
lg2 (x), log2 (x) | двоичный логарифм x
fact (x) | факториал x

Кнопка тестирования

2. Кнопка тестирования
Нажмите кнопку Тест, для того чтобы проверить корректность введенной формулы.

Кнопки сохранения или отмены изменений

3. Кнопки сохранения или отмены изменений
Нажмите кнопку Ок, для того чтобы зафиксировать изменения в формуле или Отмена, для того чтобы отменить их.


Раздел: Настройки виртуальных каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Настройки виртуальных каналов
← Пред
След →

Настройки виртуальных каналов

Виртуальные каналы всегда отображаются в панели источника, даже если на компьютере не установлен ОРС сервер. Группа виртуальных каналов называется InternalItem, и все они по умолчанию относятся к единственному прибору ITag. Виртуальные каналы могут относиться к аналоговому и логическому типу. Тип виртуального канала задается пользователем при его настройке. Кроме того, виртуальные каналы подразделяются на каналы без скрипта, со скриптом, запускаемым по таймеру и со скриптом, запускаемым по записи.
Свойства текущего активного виртуального канала отображаются в левой панели Редактора каналов. Помимо общих свойств, для виртуального канала можно настроить скрипт и определить его способ запуска:

Содержание раздела Настройки виртуальных каналов

Скрипты виртуальных каналов
Добавление скриптов виртуальным каналам
Канал без скрипта
Канал со скриптом, запускаемым по таймеру
Канал со скриптом, запускаемым по записи


Раздел: Скрипты виртуальных каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Настройки виртуальных каналов
  • Скрипты виртуальных каналов
← Пред
След →

Скрипты виртуальных каналов

Скрипты — это программы, которые обслуживают виртуальные каналы и определяют логику изменения их значений. Скрипт является основным способом оперирования данными виртуальных каналов. Скрипты являются мощным и гибким средством моделирования технологических процессов.
Редактор каналов предоставляет компактный и удобный интерфейс для создания скриптов. Встроенный Редактор скриптов, фактически, является полноценной программной средой для создания, компиляции, тестирования и выполнения скриптов. Пользователь может выбрать один из следующих языков программирования:
  • С++
  • Basic
  • Pascal
  • Java
Кроме того, можно выбрать способ запуска скрипта при выполнении проекта:
  • по таймеру: в этом случае необходимо задать временной интервал запуска в свойствах виртуального канала
  • по записи в канал: скрипт будет запускаться в случае, если пользователь инициирует изменение значения канала
Скрипты оперируют значениями активных каналов в переделах существующего проекта. Значение канала можно передать скрипту по имени, заданному строковой переменной. Также в пакете SIMP Light определены стандартные процедуры для основных функций работы с каналами: чтение и запись в канал, считывание информации из текстового файла, запуск мнемосхемы и др.


Раздел: Добавление скриптов виртуальным каналам

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Настройки виртуальных каналов
  • Добавление скриптов виртуальным каналам
← Пред
След →

Добавление скриптов виртуальным каналам

Для того чтобы добавить скрипт виртуальному каналу, необходимо выполнить следующее:
1. Выберите в списке активных каналов виртуальный канал без скрипта (иконка изображает разорванную стрелку):
2. Перейдите в активизированную панель свойств выбранного канала и нажмите кнопку добавления и настройки скрипта:
3. Откроется окно выбора синтаксиса и типа запуска скрипта:
Добавление скриптов виртуальным каналам

Выбор синтаксиса скрипта

1. Выбор синтаксиса скрипта
Выберите один из доступных языков программирования из списка.

Выбор типа запуска скрипта

2. Выбор типа запуска скрипта
Выберите один из следующих типов запуска скрипта:
  • Выполнять циклично по таймеру:
Скрипт запускается циклично с частотой заданного временного интервала (свойство Интервал опроса в настройках виртуального канала).
  • Выполнять по событию записи в канал:
Скрипт срабатывает всякий раз, когда пользователь записывает данные в канал. Это может происходить автоматически в рамках другого скрипта (в этом случае внешний скрипт вызывает специальную процедуру записи) или вручную. У виртуального канала с таким типом запуска отсутствуют свойства Интервал опроса и Интервал сохранения в БД. Также, значение такого канала нельзя сохранить в БД текущего проекта (флаг Сохранять в БД).

Создание или отмена скрипта

3. Создание или отмена скрипта
Нажмите Ок, для того чтобы создать скрипт и запустить Редактор скриптов.


Раздел: Канал без скрипта

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Настройки виртуальных каналов
  • Канал без скрипта
← Пред
След →

Канал без скрипта

Если у текущего канала отсутствует скрипт, то соответствующее поле в панели свойств выглядит следующим образом:
Других отличий в свойствах виртуального канал без скрипта не имеется (см. Общие настройки каналов). Отсутствие скрипта означает, что значение виртуального канала должно быть задано пользователем в режиме реального времени при выполнении другого скрипта. Как правило, такой канал является дискретным каналом-переключателем. Скрипт, обслуживающий другой виртуальный канал, запускается после выставления переключателя пользователем.
В состав пакета SIMP Light включен стандартный пример моделирования системы охлаждения реактора. При запуске скрипта виртуального канала Температура в реакторе можно наблюдать, что температура падает только в случае выставления канала-переключателя DI2.Охлаждение в True:
Канал без скрипта

Канал-переключатель без скрипта

1. Канал-переключатель без скрипта
Служит определяющим условием для запуска скрипта и выставляется пользователем.

Температура в реакторе

2. Температура в реакторе
Уменьшается только в случае выставления переключателя.


Раздел: Канал со скриптом, запускаемым по таймеру

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Настройки виртуальных каналов
  • Канал со скриптом, запускаемым по таймеру
← Пред
След →

Канал со скриптом, запускаемым по таймеру

Канал со скриптом, запускаемым по таймеру, наиболее часто используется для моделирования считывания информации о состоянии внешнего устройства. Рабочий скрипт данного канала запускается циклически, через равные промежутки времени, определенные пользователем. Панель свойств канала со скриптом, запускаемым по таймеру, выглядит следующим образом:
Канал со скриптом, запускаемым по таймеру

Интервал запуска скрипта

1. Интервал запуска скрипта
Это свойство содержит длительность временного промежутка между циклическими запусками скрипта канала. Используется для моделирования обращения к ОРС серверу и считывания данных из канала.

Поле редактирования скрипта

2. Поле редактирования скрипта
Поле редактирования скрипта отображает язык программирования, на котором написан скрипт. При нажатии на кнопку редактирования скрипта запускается Редактор скриптов.
Остальные свойства виртуального канала со скриптом, запускаемым по таймеру, совпадают с общими настройками каналов.


Раздел: Канал со скриптом, запускаемым по записи

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Редактирование профилей каналов
  • Настройки виртуальных каналов
  • Канал со скриптом, запускаемым по записи
← Пред
След →

Канал со скриптом, запускаемым по записи

Канал со скриптом, запускаемым по событию записи в канал, используется для моделирования технологических процессов, инициируемых пользователем. Работа с данным виртуальным каналом начинается после того, как пользователь записал в него исходные данные. Панель свойств канала со скриптом, запускаемым по записи в канал, выглядит следующим образом:
Канал со скриптом, запускаемым по записи
У данного канала отсутствуют свойства:
  • Интервал опроса
  • Интервал сохранения в БД
  • Сохранять в БД
Таким образом, значение такого канала нельзя сохранить в базе данных текущего проекта. Остальные свойства виртуального канала со скриптом, запускаемым по событию записи, совпадают с общими настройками каналов.


Раздел: Запуск теста ОРС каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Запуск теста ОРС каналов
← Пред
След →

Запуск теста ОРС каналов

Команда запуска теста каналов ОРС сервера выводит на экран текущие значения активных каналов в режиме реального времени. Для запуска теста каналов ОРС сервера необходимо добавить тестируемые каналы в панель списка активных каналов и нажать кнопку Запустить тест ОРС каналов:
Эта команда открывает окно теста ОРС каналов, в котором выводятся имена и значения активных каналов ОРС сервера в режиме реального времени:
Запуск теста ОРС каналов
simp@miniscada.com
http://miniscada.com/allproducts/simp-light


Раздел: Копирование свойств каналов

  • Редактор каналов SIMP Light
  • Работа с каналами
  • Копирование свойств каналов
← Пред
След →

Копирование свойств каналов

Для того чтобы скопировать свойства канала в другой, необходимо выделить канал в списке активных каналов, вызвать контекстное меню нажатием левой кнопки мыши и выбрать команду Скопировать свойства канала или нажать Ctrl+C:
Копирование свойств каналов
Свойства данного активного канала будут занесены в буфер. Выберите другой активный канал и нажмите Ctrl+V или выберите команду Вставить свойства канала из контекстного меню. Все общие свойства первоначального канала, кроме имени и соответствующего скрипта (если канал виртуальный) будут скопированы.


Раздел: Работа с проектами

  • Редактор каналов SIMP Light
  • Работа с проектами
← Пред
След →

Работа с проектами

Редактор каналов позволяет сохранять все изменения в настройках активных каналов и их свойствах, а также переключаться между различными компонентами пакета SIMP Light для управления проектами, редактирования мнемосхемы и просмотра текущего состояния проекта.

Содержание раздела Работа с проектами

Переключение между модулями
Сохранение изменений в проекте


Раздел: Переключение между модулями

  • Редактор каналов SIMP Light
  • Работа с проектами
  • Переключение между модулями
← Пред
След →

Переключение между модулями

Редактор каналов позволяет пользователю быстро переключаться между различными компонентами и модулями SIMP Light:
  • Редактор мнемосхем можно запустить из меню Настройка, а также из панели инструментов в нижней части списка активных каналов.
  • Менеджер проектов можно запустить из меню Настройка.
  • Монитор можно запустить из панели инструментов в нижней части списка активных каналов.
Переключение между модулями

Запуск редактора мнемосхем

1. Запуск редактора мнемосхем
Редактор мнемосхем позволяет редактировать установки мнемосхемы текущего проекта. Мнемосхема определяет логические взаимосвязи между группами каналов.

Запуск менеджера проектов

2. Запуск менеджера проектов
Менеджер проектов позволяет переключаться между текущими проектами и создавать их резервные копии.

Запуск редактора мнемосхем

3. Запуск редактора мнемосхем

Запуск Монитора

4. Запуск Монитора
Монитор позволяет отслеживать текущее состояние проекта. При необходимости, данные о текущем состоянии заносятся в журнал.


Раздел: Сохранение изменений в проекте

  • Редактор каналов SIMP Light
  • Работа с проектами
  • Сохранение изменений в проекте
← Пред
След →

Сохранение изменений в проекте

Для сохранения текущих изменений в отображении каналов на сервере и настройках активных каналов нажмите кнопку Сохранить главного меню приложения или панели инструментов списка активных каналов:
После этого появится диалоговое окно, запрашивающее подтвердить сохранение изменений. Нажатие кнопки Ок завершает сохранение настроек Редактора каналов.


Раздел: Настройки редактора каналов

  • Редактор каналов SIMP Light
  • Настройки редактора каналов
← Пред
След →

Настройки редактора каналов

Редактор каналов позволяет настраивать общие параметры пакета SIMP Light, а именно:
  • установки оповещений о критическом состоянии канала
  • включение автосохранения опций редактора каналов
  • управление доступом к настройкам текущего проекта
  • синхронизация записи в канал
  • настройка печати данных о текущем состоянии проекта
Для того чтобы вызвать диалоговое окно настроек пакета, выберите пункт Общие настройки из главного меню Редактора каналов:
Настройки редактора каналов

Команда вызова окна настроек

1. Команда вызова окна настроек
Данная команда запускает окно редактора настроек SIMP Light:
После завершения работы с окном общих настроек нажмите кнопку Применить для сохранения изменений.

Содержание раздела Настройки редактора каналов

Настройки оповещений
Настройки автосохранения
Настройки доступа
Синхронная запись в канал
Настройка печати


Раздел: Настройки оповещений

  • Редактор каналов SIMP Light
  • Настройки редактора каналов
  • Настройки оповещений
← Пред
След →

Настройки оповещений

Редактор каналов позволяет установить режим автоматических оповещений о текущем состоянии проекта. Оповещение — это сообщение, с помощью которого программа мониторинга SIMP Light сигнализирует диспетчеру о достижении критического (граничного) состояния в каком-либо из активных и видимых каналов. Оповещения отображаются в главном окне Монитора и сохраняются в журнале тревог. Пользователь также может установить режим звуковых оповещений и оповещений по электронной почте. Управление этими параметрами осуществляется с помощью окна общих настроек (Главное меню Редактора каналов -> Настроить -> Общие настройки):

Контроль квитирования

Если данный флаг установлен, то Монитор автоматически следит за состоянием канала и оповещает оператора о достижении граничных значений. Подробнее здесь.

Вывод звука на динамик PC

Флаг определяет способ вывода звуковых оповещений. Если включен режим квитирования, то Монитор подает звуковой сигнал о нарушении границ значения канала. В данном случае звук выводится на внутренний динамик компьютера.

Вывод звука через звуковую карту

Флаг определяет способ вывода звуковых оповещений. Если включен режим квитирования, то Монитор подает звуковой сигнал о нарушении границ значения канала. В данном случае звук выводится через звуковую карту на внешнее устройство.

Оповещение о тревогах на E-Mail

Данный флаг устанавливает оповещения по электронной почте. Для управления параметрами электронной почты нажмите кнопку Настроить. Подробнее о настройках электронной почты здесь.

Содержание раздела Настройки оповещений

Контроль квитирования
Оповещения по электронной почте


Раздел: Контроль квитирования

  • Редактор каналов SIMP Light
  • Настройки редактора каналов
  • Настройки оповещений
  • Контроль квитирования
← Пред
След →

Контроль квитирования

Механизм контроля квитирования осуществляется следующим образом:
1. Монитор считывает данные из канала и сверяется с установленными в Редакторе каналов граничными значениями (уставками).
2. Если достигнуто граничное значение канала, то Монитор подает звуковой и графический сигнал. В случае нарушения установленных границ окно Монитора выглядит следующим образом:
Текстовое поле с необработанным критическим значением в списке каналов вне зоны установок мигает желтым цветом. Дополнительно подается звуковой сигнал.
3. Текстовое поле перестанет мигать после того, как оператор заметит нарушение и нажмет правую кнопку мыши в области поля. В журнале тревог Монитора будет зафиксировано сообщение о квитировании сигнала (своевременном оповещении оператора):
Контроль квитирования позволяет своевременно оповещать диспетчеров устройств о критическом состоянии активных каналов, а также отслеживать оперативность их действий по отладке состояния устройства.


Раздел: Оповещения по электронной почте

  • Редактор каналов SIMP Light
  • Настройки редактора каналов
  • Настройки оповещений
  • Оповещения по электронной почте
← Пред
След →

Оповещения по электронной почте

Для настройки оповещений по электронной почте необходимо перейти в диалоговое окно параметров электронной почты (Главное меню Редактора каналов -> Настроить -> Общие настройки -> кнопка Настроить):
Оповещения по электронной почте

Параметры учетной записи

1. Параметры учетной записи
В данной панели пользователю необходимо настроить доступ к почтовому ящику, с которого в дальнейшем будут отправляться извещения о нарушении граничных значений канала (уставок). Для этого необходимо задать:
  • Адрес почтового сервера
  • Порт доступа
  • Имя пользователя почтового ящика
  • Пароль к почтовому ящику
Данные об адресе почтового сервера SMTP и порте доступа можно узнать на сайте вашей почтовой службы или организации. Например, для сервера mail.ru параметры будут следующими:
Адрес: smtp.mail.ru
Порт: 25
Имя пользователя: nnn@mail.ru

Адресаты

В этом окне необходимо ввести электронные адреса получателей извещений о нарушении уставок активных каналов. Адресатов может быть несколько, в этом случае почтовые адреса разделяются запятыми.

Оповещать при выходе за зону уставок

Если установлен данный флаг, то сообщение будет выслано только при выходе значения активного канала за предписанные границы.

Оповещать при возвращении в норму

Если установлен данный флаг, то сообщение будет выслано только при возврате значения активного канала в предписанные границы.

Протестировать

Нажмите данную кнопку для тестирования настроек доступа к электронной почте.

Завершение работы с настройками электронной почты

После завершения настройки электронной почты нажмите Ок для сохранения внесенных изменений.


Раздел: Настройки автосохранения

  • Редактор каналов SIMP Light
  • Настройки редактора каналов
  • Настройки автосохранения
← Пред
След →

Настройки автосохранения

Редактор каналов позволяет пользователю установить режим автоматического сохранения текущих настроек проекта и изменений в свойствах каналов. Для включения автосохранения откройте окно общих настроек (Главное меню Редактора каналов -> Настроить -> Общие настройки):

Автосохранение изменений

1. Автосохранение изменений
Если данный флаг установлен, то все изменения в Редакторе каналов сохраняются автоматически при переключении (смене фокуса) между открытыми окнами приложений SIMP Light. Автосохранение удобно использовать на этапе проектирования мнемосхемы и конфигурирования каналов.


Раздел: Настройки доступа

  • Редактор каналов SIMP Light
  • Настройки редактора каналов
  • Настройки доступа
← Пред
След →

Настройки доступа

Редактор каналов позволяет пользователю установить режим доступа к редактированию настроек проекта. Кроме того, допускается настройка доступа к значениям каналов через веб-интерфейс. Управление этими параметрами осуществляется с помощью окна общих настроек (Главное меню Редактора каналов -> Настроить -> Общие настройки):

Разрешить WEB сервер

1. Разрешить WEB сервер
Установка данного флага позволяет просматривать значения каналов с помощью WEB-интерфейса, то есть в любом стандартном приложении-браузере.

Требовать авторизации

2. Требовать авторизации
Установка данного флага включает режим авторизации для защиты доступа к изменению настроек текущего проекта. Режим авторизации является активным при работе с Редактором каналов и Монитором. Подробнее здесь.

Содержание раздела Настройки доступа

Настройка авторизации


Раздел: Настройка авторизации

  • Редактор каналов SIMP Light
  • Настройки редактора каналов
  • Настройки доступа
  • Настройка авторизации
← Пред
След →

Настройка авторизации

По умолчанию Редактор каналов запускается в режиме редактирования данных. Настройка авторизации позволяет включить режим защиты данных, в котором программа допускает редактирование данных только после ввода соответствующего логина и пароля. Для включения авторизации необходимо сделать следующие шаги:
  1. Перейдите в диалоговое окно общих настроек (Главное меню Редактора каналов -> Настроить -> Общие настройки) и включите флаг Требовать авторизации.
  2. После этого главное окно Редактора каналов будет выглядеть следующим образом:

Знак активизации режима защиты данных

1. Знак активизации режима защиты данных
Наличие данного знака в правом верхнем углу главного окна Редактора каналов свидетельствует о том, что режим защиты данных активизирован. Пользователь может внести изменения в панели свойств активного канала или остановить работу Монитора только после того, как он введет правильный логин и пароль. По умолчанию вносить любые изменения в Редакторе каналов запрещено. При попытке изменить какое-либо свойство текущего канала выдается предупреждающее сообщение:
Для включения доступа к вышеперечисленным функциям, необходимо ввести логин и пароль. Для этого служит пункт главного меню Доступ.

Пункт меню настройки доступа

2. Пункт меню настройки доступа
Данный пункт главного меню Редактора каналов служит для ввода и редактирования пользовательского логина и пароля:
1. После выбора данного пункта меню открывается диалоговое окно авторизации:
2. В текстовые поля необходимо ввести корректные данные для настройки доступа.
Внимание! По умолчанию после первого запуска Редактора каналов установлены следующие данные для авторизации пользователя:
логин: user
пароль: user
3. Если пользовательские данные введены корректно, то появится сообщение об успешной авторизации. После этого знак активизации режима защиты данных (1) не будет отображаться в главном окне приложения. Пользователь сможет вносить изменения в настройки Редактора каналов.
В случае ввода неправильных данных режим защиты не будет снят. Монитор будет запрашивать пароль при выходе.
4. Для смены текущего пароля или логина:
4.1. Нажмите в окне ввода логина и пароля кнопку Сменить пароль. Откроется диалоговое окно установки нового логина и/или пароля:
4.2. Для смены пароля или логина необходимо ввести текущий логин и пароль, новый логин, пароль и подтвердить его. После нажатия кнопки Ок изменения вступят в силу.


Раздел: Синхронная запись в канал

  • Редактор каналов SIMP Light
  • Настройки редактора каналов
  • Синхронная запись в канал
← Пред
След →

Синхронная запись в канал

Редактор каналов позволяет пользователю настраивать режим синхронизации записи данных в канал. Пакет SIMP Light поддерживает наиболее широко используемый стандарт OPC DA версии 2.05a. В этом стандарте помимо синхронного обмена данными, введена поддержка асинхронного обмена данными. Асинхронный обмен данными позволяет продолжать выполнение основного приложения без ожидания ответа от устройства нижнего уровня. Этот метод существенно снижает нагрузку на сеть и уменьшает риск зависаний программ работы с внешними устройствами. Режим асинхронной записи используется пакетом SIMP Light по умолчанию.
Для смены режима синхронизации откройте окно общих настроек (Главное меню Редактора каналов -> Настроить -> Общие настройки):
Синхронная запись в канал

Синхронная запись в канал (ОРС)

1. Синхронная запись в канал (ОРС)
Установка данного флага включает режим синхронной записи в ОРС канал. В обратном случае автоматически используется асинхронный режим записи в канал. Это значение установлено по умолчанию.


Раздел: Настройка печати

  • Редактор каналов SIMP Light
  • Настройки редактора каналов
  • Настройка печати
← Пред
След →

Настройка печати

Редактор каналов позволяет пользователю задать шаблонную строку, которая будет автоматически добавляться в начало документа при распечатке отчетов пакета SIMP Light. Как правило, в качестве стандартной строки в шапке отчета фигурирует название организации. Для ввода шаблонной строки откройте окно общих настроек (Главное меню Редактора каналов -> Настроить -> Общие настройки):

Дополнительная информация при печати

В это окно следует внести данные, которые будут добавляться в шапки всех отчетов при печати из приложений SIMP Light (Модуль просмотра графиков и Журнал тревог Монитора).


Раздел: Монитор SIMP Light

  • Монитор SIMP Light
← Пред
След →

Монитор SIMP Light

Монитор SIMP Light позволяет отслеживать текущие параметры активных каналов ОРС сервера и контролировать их состояние. Наиболее существенными чертами Монитора являются:
  • Просмотр оперативной информации о состоянии активных каналов в режиме реального времени
  • Своевременное оповещение о критическом состоянии канала и автоматическая запись оповещения в журнал тревог
  • Отображение текущего состояния каналов в виде мнемосхем, графиков, трендов и журнала тревог.

Содержание раздела Монитор SIMP Light

Обзор функциональности модуля
Работа с активными каналами
Работа со значениями вне зоны уставок
Работа с мнемосхемой
Работа с журналом оповещений
Просмотр графиков
Работа в защищенном режиме
Настройки мониторинга


Раздел: Обзор функциональности модуля

  • Монитор SIMP Light
  • Обзор функциональности модуля
← Пред
След →

Обзор функциональности модуля

Монитор SIMP Light предназначен для просмотра оперативной информации о состоянии каналов ОРС сервера.
1. Работа с активными каналами
Список активных каналов ОРС сервера и их значений всегда отображается в главном окне Монитора. Активность канала настраивается в Редакторе каналов SIMP Light и определяет его наличие в процессе мониторинга и сбора данных. Бесплатная версия SIMP Light обладает ограничениями по количеству добавленных каналов.
2. Работа с критическими значениями
Наиболее важная часть функциональности Монитора — это контроль и оповещение пользователя (диспетчера устройств) о том, что состояние канала приближается к нижней или верхней допустимой границе значений. Оповещения всегда заносятся в журнал тревог. Также, критические состояния могут квитироваться (отслеживаться пользователем).
3. Работа с мнемосхемой
Монитор можно переключить в режим наблюдения за текущим состоянием мнемосхемы проекта. Мнемосхема отображает устройства сервера в виде графических компонент. Пользователь может изменять состояние параметров мнемосхемы и просматривать тренды (графики значений) каналов.
4. Работа с журналом оповещений
Журнал оповещений служит для записи информации о дате, времени и квитировании отслеженных критических состояний канала. Журнал ведется автоматически.
5. Переход к модулю просмотра графиков
6. Защищенный режим
7. Настройки Монитора
Главное окно Монитора включает в себя две активных области (панели):
Список параметров отображает имена и значения текущих активных каналов, выбранных для мониторинга и контроля состояний.
Список каналов вне зоны уставок отображает значения каналов вне установленных допустимых границ. Для настройки граничных квитируемых значений служит Редактор каналов SIMP Light (см. раздел Редактирование профилей каналов ).
Главное меню Монитора служит для того, чтобы переключаться между различными видами представления текущей информации о канале: мнемосхема, журнал тревог и модуль просмотра графиков.


Раздел: Работа с активными каналами

  • Монитор SIMP Light
  • Работа с активными каналами
← Пред
След →

Работа с активными каналами

Монитор SIMP Light обеспечивает просмотр и контроль сбора данных с доступных ОРС серверов. ОРС сервер — это программное обеспечение, предназначенное для сбора, передачи и синхронизации информации о внешних устройствах нижнего уровня, подключенных к компьютеру, таких как программируемые логические контроллеры и распределенные системы управления. Пакет SIMP Light также позволяет работать с внутренним сервером виртуальных каналов, эмулирующим работу внешних физических устройств с помощью программируемых скриптов.
Монитор отображает активные каналы физического ОРС сервера или виртуальные каналы в зависимости от настроек Редактора каналов . Для добавления или удаления активных каналов, изменения режима видимости каналов и границ уставок (допустимых квитируемых значений канала) необходимо обратиться к администратору Редактора каналов .

Содержание раздела Работа с активными каналами

Просмотр списка активных каналов
Просмотр информации о каналах
Просмотр трендов


Раздел: Просмотр списка активных каналов

  • Монитор SIMP Light
  • Работа с активными каналами
  • Просмотр списка активных каналов
← Пред
След →

Просмотр списка активных каналов

Монитор SIMP Light отображает информацию о текущем состоянии виртуального или физического канала ОРС сервера. Значения каналов отображаются в списке параметров:
Просмотр списка активных каналов

Названия каналов

1. Названия каналов
Список имен активных каналов ОРС сервера. Если канал активен, но его видимость выключена в Редакторе каналов, Монитор не отслеживает значение канала. Состояние таких каналов отображается только на мнемосхеме проекта.

Значения каналов

2. Значения каналов
Список значений видимых активных каналов ОРС сервера. Формат значения указывается в Редакторе каналов. Для вычисления текущего значения канала может использоваться программируемый скрипт (виртуальный канал) или математическая формула, преобразующая исходные данные (физический канал). Этими настройками можно управлять с помощью Редактора каналов.


Раздел: Просмотр информации о каналах

  • Монитор SIMP Light
  • Работа с активными каналами
  • Просмотр информации о каналах
← Пред
След →

Просмотр информации о каналах

Для того чтобы открыть список свойств канала, необходимо выбрать канал и нажать на появившейся кнопке со знаком информации о канале:
Данная команда вызывает окно со списком свойств текущего канала:
Просмотр информации о каналах

Наименование параметра

1. Наименование параметра
Имя текущего канала.

Тип канала

2. Тип канала
Тип переменной канала: логический (для каналов-переключателей с двумя возможными значениями) или аналоговый.

Верх и низ шкалы

3. Верх и низ шкалы
Интервал возможных значений канала.

Уставка верх и низ

4. Уставка верх и низ
Пользовательские ограничения значений канала, определяющие зону квитируемых значений, при достижении которых выдается автоматическое оповещение.

Тип переменной

5. Тип переменной
Тип данных, к которому преобразуется считанная из канала информация: логический, численный (вещественный или целочисленный), дата и время или строковый и т.д.

Измеряемая величина

6. Измеряемая величина
Единица измерения значения канала.

Источник

Ссылка на физический адрес источника устройства канала: ОРС сервер или скрипт виртуального канала.


Раздел: Просмотр трендов

  • Монитор SIMP Light
  • Работа с активными каналами
  • Просмотр трендов
← Пред
След →

Просмотр трендов

Графический режим просмотра значения канала в режиме реального времени (тренд) запускается при двойном щелчке мышью на выбранном канале в списке параметров. Тренд отражает динамику состояния канала:

Шкала значений канала

Указывает возможные границы изменения значений канала.

Тренд

Тренд — это графическое представление текущих данных канала.

Временная шкала

Фиксирует время и соответствующее значение канала. По умолчанию, одно деление шкалы соответствует двум минутам.

Кнопки управления просмотром тренда

4. Кнопки управления просмотром тренда
  • Старт: снова запускает остановленный тренд после работы режима включенного увеличения и курсора.
  • Курсор: останавливает тренд и позволяет пользователю просмотреть значения на графике.
  • Назад и вперед: позволяют пролистать график тренда по временной шкале.
  • Включить увеличение: останавливает тренд и позволяет пользователю просмотреть увеличенное изображения тренда.
  • Интервал: устанавливает временной промежуток для отдельной страницы тренда.

Содержание раздела Просмотр трендов

Режим включенного увеличения
Установка интервала тренда
Режим курсора


Раздел: Режим включенного увеличения

  • Монитор SIMP Light
  • Работа с активными каналами
  • Просмотр трендов
  • Режим включенного увеличения
← Пред
След →

Режим включенного увеличения

Для того чтобы включить увеличение тренда, необходимо сделать следующие шаги:
  1. Нажмите кнопку Включить увеличение (значок лупы) в панели тренда.
  2. После этого кнопка Старт станет активной, так как в режиме увеличения тренд останавливается.
  3. Нажмите левую кнопку мыши, и, не отпуская ее, выделите прямоугольную область в окне тренда:
Режим включенного увеличения
4. После окончания работы с режимом увеличения, нажмите Старт для запуска тренда.


Раздел: Установка интервала тренда

  • Монитор SIMP Light
  • Работа с активными каналами
  • Просмотр трендов
  • Установка интервала тренда
← Пред
След →

Установка интервала тренда

Для установки временного интервала страницы тренда нажмите кнопку Интервал (двухсторонняя стрелка) в панели тренда. Появится меню с опциями для установки интервала:
Установка интервала тренда
Выберите интервал. Это значение будет использоваться для масштабирования тренда по временной шкале.


Раздел: Режим курсора

  • Монитор SIMP Light
  • Работа с активными каналами
  • Просмотр трендов
  • Режим курсора
← Пред
След →

Режим курсора

Для того чтобы включить курсор, необходимо сделать следующие шаги:
1. Нажмите кнопку Курсор (значок курсора) в панели тренда.
2. После этого кнопка Старт станет активной, так как в режиме увеличения тренд останавливается. В окне тренда появится синяя линия (курсор), с данными о значении канала в выделенный момент времени:
3. Курсор можно перетаскивать с помощью мыши для просматривания значения канала в различные моменты времени.
4. После окончания работы с режимом курсора, нажмите Старт для запуска тренда.


Раздел: Работа со значениями вне зоны уставок

  • Монитор SIMP Light
  • Работа со значениями вне зоны уставок
← Пред
След →

Работа со значениями вне зоны уставок

Основной функцией Монитора является автоматическое отслеживание и контролирование значений видимых активных каналов. Значения вне зоны уставок — это контрольные граничные значения канала, о достижении которых Монитор автоматически извещает диспетчера устройств ОРС сервера.
Информация о достижении значения вне зоны уставок всегда автоматически записывается в журнал тревог. Если пользователь отметил критическое состояние канала, то в журнале появится запись о квитировании значения канала. Если выход значения канала из установленной допустимой зоны не был отмечен (не квитирован), то информация об этом также запишется в журнал. Таким образом, Монитор позволяет вести контроль оперативности реагирования диспетчера устройств ОРС сервера.

Содержание раздела Работа со значениями вне зоны уставок

Просмотр значений вне зоны уставок
Контроль значений вне зоны уставок


Раздел: Просмотр значений вне зоны уставок

  • Монитор SIMP Light
  • Работа со значениями вне зоны уставок
  • Просмотр значений вне зоны уставок
← Пред
След →

Просмотр значений вне зоны уставок

После запуска Монитор начинает непрерывно считывать информацию с активных каналов. Правая панель главного окна Монитора служит для отображения текущих значений каналов вне зоны уставок:
Просмотр значений вне зоны уставок

Значение выше уставки

1. Значение выше уставки
Значение выше допустимой верхней границы уставки отображается миганием и красным цветом. Иконка изображает красную стрелку, указывающую вверх.

Значение ниже уставки

2. Значение ниже уставки
Значение ниже допустимой нижней границы уставки отображается миганием и желтым цветом. Иконка изображает желтую стрелку, указывающую вниз.
Если в Редакторе каналов настроена соответствующая опция, то Монитор также подает звуковой сигнал через звуковую карту или динамик компьютера при достижении каналом значения вне границ уставок.


Раздел: Контроль значений вне зоны уставок

  • Монитор SIMP Light
  • Работа со значениями вне зоны уставок
  • Контроль значений вне зоны уставок
← Пред
След →

Контроль значений вне зоны уставок

Для того чтобы указать Монитору об отметке значения вне зоны уставок, его необходимо квитировать. Квитирование — это подтверждение со стороны оператора о том, что он увидел и принял к сведению выход технологического параметра за норму. Для этого служит щелчок мышью на выбранном значении в списке каналов вне зоны уставок:
Контроль значений вне зоны уставок

Значение квитировано

1. Значение квитировано
После квитирования (отметки) значения вне зоны уставок, Монитор перестает подавать звуковой сигнал, и мигание надписи прекращается. В журнал тревог будет записана отметка о квитировании значения.
Диспетчер не может добавлять или удалять каналы из списка каналов вне зоны уставок. Канал удаляется из списка автоматически, если его значение снова находится в допустимых пределах. Контролировать изменение значения канала можно в режиме мнемосхемы.


Раздел: Работа с мнемосхемой

  • Монитор SIMP Light
  • Работа с мнемосхемой
← Пред
След →

Работа с мнемосхемой

Монитор позволяет пользователю переключиться в режим мнемосхемы, то есть графического представления функциональных компонент текущего проекта. Мнемосхема состоит из:
  • функциональных устройств (каналов или тегов), с которых считываются и регистрируются данные
  • внутренних связей, обеспечивающих сообщение между компонентами схемы
  • переключателей, которые позволяют контролировать состояние параметров мнемосхемы
  • сигнальных устройств или датчиков состояний
Для перехода к режиму мнемосхемы необходимо выбрать соответствующий пункт главного меню Монитора:
В текущем проекте может фигурировать несколько мнемосхем для отображения различных участков работы. Редактор мнемосхем SIMP Light позволяет создавать и настраивать мнемосхемы.

Содержание раздела Работа с мнемосхемой

Обзор компонент мнемосхемы
Изменение параметров мнемосхемы
Просмотр трендов


Раздел: Обзор компонент мнемосхемы

  • Монитор SIMP Light
  • Работа с мнемосхемой
  • Обзор компонент мнемосхемы
← Пред
След →

Обзор компонент мнемосхемы

Мнемосхема — это удобный способ визуализации информации о состоянии рабочих каналов и их взаимосвязей. Работа с мнемосхемой позволяет избежать ошибок неверного контролирования состояния устройств ОРС сервера. Стандартные графические компоненты схем описаны подробнее в Редакторе мнемосхем.
Обзор компонент мнемосхемы

Тренд

Тренд (график) отражает динамику изменения значения соответствующего канала.

Датчик значения канала

2. Датчик значения канала
Датчик показывает текущее значение канала на мнемосхеме.

Имя канала и графический объект

Каналы (внешние устройства) отображены на схеме в виде графических объектов. Наведение курсора мыши на графический объект вызывает всплывающую подсказку с краткой информацией о канале, к которому привязан этот компонент:
  • имя канала
  • нижняя и верхняя уставки

Труба

Труба связывает взаимозависимые компоненты схемы.

Переключатель

Устройство переключения служит для контроля состояния мнемосхемы и управления остальными ее параметрами. Визуально отображается в виде заглушки с двумя состояниями (закрытое и открытое).


Раздел: Изменение параметров мнемосхемы

  • Монитор SIMP Light
  • Работа с мнемосхемой
  • Изменение параметров мнемосхемы
← Пред
След →

Изменение параметров мнемосхемы

Режим мнемосхемы позволяет оператору внешних устройств настроить параметры текущего проекта. Щелкнув левой кнопкой мыши на канале-переключателе (1 и 2 на рисунке ниже), пользователь изменяет его состояние на закрытое/открытое:
Изменение параметров мнемосхемы

Переключатель закрыт

1. Переключатель закрыт
Соответствующее булево значение логического канала установлено в 0. Переключатель отображен красным цветом на схеме.

Переключатель открыт

2. Переключатель открыт
Соответствующее булево значение установлено в 1. Переключатель отображается зеленым цветом, и на соответствующей связующей трубе указывается стрелкой направление сообщения.
Канал-переключатель — это как правило логический канал, принимающий лишь значения 0 и 1. Он служит триггером для запуска технического процесса на реальном ОРС сервере или моделирующего скрипта виртуального канала.


Раздел: Просмотр трендов

  • Монитор SIMP Light
  • Работа с мнемосхемой
  • Просмотр трендов
← Пред
След →

Просмотр трендов

Двойной щелчок левой кнопкой мыши на датчике значения канала открывает соответствующий тренд для просмотра. Также, тренды для фиксированных каналов могут быть встроены в мнемосхему:

Встроенный тренд

Встроенный тренд отражает динамику только одного заранее заданного канала.

Тренд датчика значения канала

Тренд любого канала с датчиком значений. Настройки просмотра такого тренда см. выше.


Раздел: Работа с журналом оповещений

  • Монитор SIMP Light
  • Работа с журналом оповещений
← Пред
След →

Работа с журналом оповещений

Журнал оповещений (тревог) служит для архивирования данных о тревогах (значениях каналов вне установленных границ), произошедших во время работы Монитора. Также, журнал содержит информацию о квитировании значений. Квитирование — это подтверждение со стороны оператора о том, что он увидел и принял к сведению выход технологического параметра за норму.
Для того чтобы вызвать окно Журнала тревог, выберите соответствующий пункт из главного меню Монитора:
Работа с журналом оповещений

Команда вызова окна журнала тревог

1. Команда вызова окна журнала тревог
Открывает окно журнала без данных. Для того чтобы просмотреть Журнал тревог, необходимо выбрать дату активности Монитора:
Содержание журналов ведется по датам запуска и работы Монитора. Это облегчает поиск нужных записей в журналах. Содержимое журналов можно фильтровать по имени канала и выводить на печать.

Содержание раздела Работа с журналом оповещений

Просмотр журнала оповещений
Фильтрация записей
Печать журнала


Раздел: Просмотр журнала оповещений

  • Монитор SIMP Light
  • Работа с журналом оповещений
  • Просмотр журнала оповещений
← Пред
След →

Просмотр журнала оповещений

Окно Журнала тревог состоит из двух панелей:
  • Доступные журналы (список дат, когда был запущен Монитор)
  • Список записей по дате (содержит время, имя канала, значение канала и оповещение)
Просмотр журнала оповещений

Панель доступных журналов

1. Панель доступных журналов
Новый журнал создается по дате запуска Монитора. Текущая дата выделена красной точкой.

Таблица записей журнала

2. Таблица записей журнала
Записи в журнале содержат следующие данные:
  1. Время — время фиксации оповещения.
  2. Позиция — имя канала, для которого выдается оповещение.
  3. Значение — текущее значение канала в момент оповещения. В случае оповещения о квитировании текущее значение канала не сохраняется.
  4. Событие — текст оповещения. Оповещение может быть о следующих событиях:
  • Значение в рабочей зоне (нет выхода за границы уставок: это сообщение записывается, если параметр был за пределами допусков, а потом вернулся в норму)
  • Значение ниже уставки (выделено желтым фоном в журнале)
  • Значение выше уставки (выделено красным фоном в журнале)
  • Квитирование сигнала (оператор отметил тревогу)


Раздел: Фильтрация записей

  • Монитор SIMP Light
  • Работа с журналом оповещений
  • Фильтрация записей
← Пред
След →

Фильтрация записей

Для того чтобы просмотреть записи в журнале, относящиеся к определенному каналу, необходимо дважды щелкнуть левой кнопкой мыши на любой записи с его именем. В списке оповещений останутся лишь данные выбранного канала:
Для того чтобы вернуться к полному списку записей, откройте текущий журнал еще раз в панели доступных журналов.


Раздел: Печать журнала

  • Монитор SIMP Light
  • Работа с журналом оповещений
  • Печать журнала
← Пред
След →

Печать журнала

Для того чтобы вывести данные журнала тревог на печать, нажмите кнопку печати в правом нижнем углу списка записей:

Кнопка печати

Запускает диалоговое окно принтера.


Раздел: Просмотр графиков

  • Монитор SIMP Light
  • Просмотр графиков
← Пред
След →

Просмотр графиков

Для того чтобы перейти к Модулю просмотра графиков SIMP Light, выберите в главном меню Монитора команду Вид -> Смотреть графики:
Эта команда открывает окно Модуля просмотра графиков:


Раздел: Работа в защищенном режиме

  • Монитор SIMP Light
  • Работа в защищенном режиме
← Пред
След →

Работа в защищенном режиме

Если в Редакторе каналов SIMP Light включен защищенный режим, то для остановки запущенного Монитора требуется авторизация. При попытке закрыть окно Монитора появится запрос о подтверждении закрытия:
Работа в защищенном режиме
Если пользователь нажимает кнопку Yes, то открывается диалоговое окно, запрашивающее ввод логина и пароля администратора настроек пакета SIMP Light:
Подробнее о защищенном режиме можно прочитать в документации Редактора каналов SIMP Light.


Раздел: Настройки мониторинга

  • Монитор SIMP Light
  • Настройки мониторинга
← Пред
След →

Настройки мониторинга

Монитор SIMP Light предназначен для сбора текущей информации об устройствах и ведения архивного журнала. Для установки параметров работы Монитора служит Редактор каналов. Следующие настройки Монитора доступны для редактирования лишь в Редакторе каналов SIMP Light:
  • Активные каналы и их количество
  • Свойства каналов: границы уставок, интервал опроса и видимость канала
  • Настройки звуковых сигналов, контроля квитирования и оповещений по электронной почте
  • Настройки печати
Подробнее об этих настройках можно прочитать в документации по Редактору каналов SIMP Light .


Раздел: Редактор мнемосхем SIMP Light

  • Редактор мнемосхем SIMP Light
← Пред
След →

Редактор мнемосхем SIMP Light

Редактор мнемосхем SIMP Light позволяет создавать, редактировать и настраивать параметры мнемосхем технологических процессов. Мнемосхема — это графическое представление сигнальных устройств и изображений оборудования, а также внутренних связей контролируемых каналов (тегов) ОРС сервера. Наиболее существенными чертами Редактора мнемосхем являются:
  • Удобный графический интерфейс, позволяющий создавать и настраивать дизайн мнемосхем
  • Возможность настраивать привязки (ассоциации) каналов ОРС сервера для графических элементов мнемосхем
  • Режим эмуляции работы мнемосхем для тестирования работоспособности ее настроек

Содержание раздела Редактор мнемосхем SIMP Light

Обзор функциональности модуля
Быстрый старт
Работа с файлами мнемосхем
Настройка вида мнемосхемы
Работа с графическими компонентами
Запуск режима эмуляции работы мнемосхемы
Запуск других модулей


Раздел: Обзор функциональности модуля

  • Редактор мнемосхем SIMP Light
  • Обзор функциональности модуля
← Пред
След →

Обзор функциональности модуля

Редактор мнемосхем SIMP Light предназначен для создания и редактирования графического представления внешних устройств, подключенных к ОРС серверу (мнемосхем).
1. Быстрый старт
Краткое руководство к созданию мнемосхемы и работе с ней.
2. Работа с файлами мнемосхем
Все мнемосхемы SIMP Light сохраняются в виде отдельных файлов. Редактор мнемосхем позволяет их создавать, открывать, редактировать и сохранять.
3. Работа с графическими компонентами
Наиболее важная часть функциональности модуля. Графические компоненты позволяют создавать и настраивать дизайн мнемосхемы, ее внутренних связей и сигнальных устройств. Редактор мнемосхем позволяет использовать такие графические компоненты как:
  • трубы
  • фигуры
  • индикаторы
  • тренды
  • изображения
  • компоненты даты и времени
  • компоненты управления
4. Настройка вида мнемосхемы
5. Запуск других модулей
6. Режим эмуляции
Режим служит для тестирования функциональности мнемосхемы и связи отдельных компонент.


Раздел: Быстрый старт

  • Редактор мнемосхем SIMP Light
  • Быстрый старт
← Пред
След →

Быстрый старт

1. Запустите Редактор мнемосхем SIMP Light.
2. Выберите пункт меню Файл -> Новый для создания нового пустого проекта мнемосхемы. Главное окно Редактора мнемосхем выглядит следующим образом:

Панель графических компонент и их свойств

Панель содержит палитру графических компонент, которые можно добавлять к мнемосхеме. Кнопка с двойной стрелкой вниз открывает панель свойств текущей активной компоненты.

Окно редактирования вида мнемосхемы

В данной области отображается визуальное представление компонент мнемосхемы. Вид компонент можно настраивать: изменять размер, положение, вид сетки, группировать и выравнивать.

Строка состояния

Отображает координаты относительно сетки, название и размеры текущей активной компоненты.
3. Для создания вашей первой мнемосхемы просто перетащите необходимые графические компоненты из палитры компонент (1) в окно редактирования (3). Для связи с каналом ОРС сервера служат графические компоненты индикаторов. Индикаторы отображают текущее значение канала в режиме реального времени в модуле Монитор SIMP Light. Редактор мнемосхем позволяет настроить представление текущего значения канала в наиболее подходящем для целей проекта виде, например:
4. После добавления и настройки графического представления проекта, необходимо установить привязки компонент (обычно, индикаторов) к каналам внешних устройств. Для этого необходимо выделить компоненту, открыть панель свойств и установить флаг привязки к каналу:
5. При установленном флаге привязки становится доступным меню выбора канала:
6. Работоспособность компонент схемы и их связей с каналами можно протестировать. Для этого служит режим эмуляции (Настройка -> Запустить режим эмуляции):
Поздравляем! Вы создали и настроили свою первую мнемосхему!


Раздел: Работа с файлами мнемосхем

  • Редактор мнемосхем SIMP Light
  • Работа с файлами мнемосхем
← Пред
След →

Работа с файлами мнемосхем

В этом разделе подробно рассмотрены операции создания, открытия и сохранения мнемосхем.

Содержание раздела Работа с файлами мнемосхем

Создание новой мнемосхемы
Открытие существующей мнемосхемы
Сохранение изменений


Раздел: Создание новой мнемосхемы

  • Редактор мнемосхем SIMP Light
  • Работа с файлами мнемосхем
  • Создание новой мнемосхемы
← Пред
След →

Создание новой мнемосхемы

Для того чтобы создать новую мнемосхему, выберите в главном меню Редактора мнемосхем пункт Файл -> Новый:
Редактор мнемосхем автоматически создаст новый файл мнемосхемы в папке текущего активного проекта. Главное окно Редактора приобретет следующий вид:
Создание новой мнемосхемы

Палитра компонент

Становится активной после создания нового проекта мнемосхемы или открытия существующего. Компоненты активной палитры можно перетаскивать в окно графического представления схемы.

Окно редактирования мнемосхемы

Отображает разметку (сетку и линейки) после создания нового проекта мнемосхемы или открытия существующего.


Раздел: Открытие существующей мнемосхемы

  • Редактор мнемосхем SIMP Light
  • Работа с файлами мнемосхем
  • Открытие существующей мнемосхемы
← Пред
След →

Открытие существующей мнемосхемы

Для открытия существующей мнемосхемы необходимо выбрать пункт меню Файл -> Открыть. Команда запустит диалоговое окно выбора файла мнемосхемы. По умолчанию диалоговое окно отображает содержимое папки текущего активного проекта:
Открытие существующей мнемосхемы
Редактор мнемосхем не позволяет изменить директорию проекта. Для смены настроек текущего проекта или работы с другим проектом необходимо использовать Менеджер проектов SIMP Light.
Контекстное меню мнемосхемы, открытой в диалоговом окне, содержит настройки автозапуска мнемосхемы:
При включенной автозагрузке мнемосхема будет запускаться автоматически при старте Монитора SIMP Light.
Выбранный файл можно просматривать, редактировать и запускать. Имя текущего файла мнемосхемы отображается в верхней части окна Редактора:


Раздел: Сохранение изменений

  • Редактор мнемосхем SIMP Light
  • Работа с файлами мнемосхем
  • Сохранение изменений
← Пред
След →

Сохранение изменений

Для сохранения изменений в меню Файл выберите Сохранить (Ctrl+S) или Сохранить как.
В настройках Редактора каналов SIMP Light можно также установить опцию автосохранения мнемосхемы.


Раздел: Настройка вида мнемосхемы

  • Редактор мнемосхем SIMP Light
  • Настройка вида мнемосхемы
← Пред
След →

Настройка вида мнемосхемы

Для настройки вида мнемосхемы служат опции меню Вид. Данное меню позволяет настроить свойства координатной сетки, а также установить флаги:
  • сетки: при включении поле редактирования отображает координатную сетку схемы
  • привязки к сетке: при включении для перемещаемых графических компонент шаг смещения становится равен делению сетки
  • линеек: при включении к полю редактирования добавляется координатная шкала по вертикали и горизонтали
  • панели компонентов: при отключении панель компонентов сворачивается, и поле редактирования схемы занимает всю область главного окна Редактора.
Настройка вида мнемосхемы

Настройка свойств сетки

1. Настройка свойств сетки
Свойства сетки можно настроить в диалоговом окне свойств:
2: Выпадающий список для настройки цвета отображаемой координатной сетки. По умолчанию выбран черный цвет.
1 и 3: выбор шага по оси X и Y для задания горизонтального и вертикального масштабирования.
Для сохранения изменений в свойствах координатной сетки нажмите Ok.

Координатная сетка

Задает координатное пространство схемы.

Панель инструментов

При сворачивании панели инструментов графическое представление мнемосхемы занимает всю область главного окна Редактора.

Линейки

Определяют шкалу координат пространства мнемосхемы.

Содержание раздела Настройка вида мнемосхемы

Свойства поля редактирования мнемосхемы


Раздел: Свойства поля редактирования мнемосхемы

  • Редактор мнемосхем SIMP Light
  • Настройка вида мнемосхемы
  • Свойства поля редактирования мнемосхемы
← Пред
След →

Свойства поля редактирования мнемосхемы

Свойства поля редактирования мнемосхемы открываются в панели свойств при нажатии левой кнопки мыши в области окна редактирования. Панель свойств поля выглядит следующим образом:
Свойства поля редактирования мнемосхемы

Цвет окна

Задает цвет фона мнемосхемы.

Изображение

Определяет подключаемый графический файл.

Авторизация

Если в Редакторе каналов настроена авторизация (см. раздел Настройка авторизации), то при включении данного флага во время открытия мнемосхемы требуется указать логин и пароль пользователя.

Во весь экран

Если включен данный флаг, то мнемосхема по умолчанию открывается во весь экран. При отключении флага становятся доступны некоторые дополнительные настройки отображения мнемосхемы:
  • Показать в списке: при включении данного флага мнемосхема отображается в списке доступных мнемосхем Монитора (см. Работа с мнемосхемой)
  • Позиция X и Y: координаты верхнего левого угла участка мнемосхемы, открытого для просмотра
  • Ширина и высота: размеры участка мнемосхемы, открытого для просмотра


Раздел: Работа с графическими компонентами

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
← Пред
След →

Работа с графическими компонентами

Палитра графических компонент отображается в левой панели главного окна Редактора мнемосхем:
Работа с графическими компонентами

Панель свойств

Содержит редактируемый список свойств активной компоненты. Пользователь может настроить графическое представление компоненты, а также текущее значение канала, связанного с компонентой.

Кнопка открытия панели свойств компоненты

2. Кнопка открытия панели свойств компоненты
По нажатию этой кнопки разворачивается панель свойств компоненты:

Палитра компонент

Палитра содержит список компонент, сгруппированных по категориям. Для добавления выбранной компоненты в поле редактирования необходимо перетащить ее с помощью мыши. Свойства выбранной компоненты отображаются в панели свойств.

Содержание раздела Работа с графическими компонентами

Обзор графических компонент
Типы графических компонент
Добавление и настройка компонент мнемосхемы
Копирование компонент мнемосхемы
Группировка компонент
Выравнивание компонент


Раздел: Обзор графических компонент

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Обзор графических компонент
← Пред
След →

Обзор графических компонент

Графические компоненты Редактора мнемосхем SIMP Light служат для представления взаимосвязей внешних устройств и логики функционирования мнемосхемы технологического процесса. С помощью графических компонент пользователь (конструктор проекта) может создать и настроить удобный графический дизайн для визуального представления работы внешних устройств ОРС сервера. Работа с мнемосхемой уменьшает вероятность ошибок диспетчера и неверных действий в случае критической ситуации в процессе работы ОРС сервера.
Графические компоненты можно разбить на три группы:
1. Визуальные компоненты
Главной функцией визуальных компонент является условное графическое отображение информации о схеме и ее связях. К визуальным компонентам относятся:
  • Фигуры
  • Трубы
  • Изображения
2. Функциональные компоненты.
Служат для отображения значений текущего канала и настраиваются в привязке к соответствующим тегам ОРС сервера. К ним относятся:
  • Индикаторы
  • Тренды
3. Компоненты общего назначения.
Служат для отображения текущей даты, времени, ввода значений и запуска других приложений и мнемосхем. К ним относятся:
  • Дополнительные компоненты
  • Компоненты управления


Раздел: Типы графических компонент

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
← Пред
След →

Типы графических компонент

1. Фигуры
Визуальные компоненты, служащие для отображения внешних устройств ОРС сервера.
Название фигуры | Вид
Прямоугольник |
Квадрат с закругленными краями |
Круг |
Емкость горизонтальная/вертикальная |
Клапаны 1-6 |
Стрелки 1-4 |
2. Трубы
Служат для визуального представления взаимосвязей устройств ОРС сервера.
Название трубы | Вид
Труба вертикальная/горизонтальная |
Угольники 1-4 |
Тройники 1-4 |
Крестовина |
3. Индикаторы
Служат для вывода текущих значений каналов ОРС сервера в виде шкалы с секторами значений.
Название индикатора | Вид
Панель/текст/динамический текст |
Радиальный индикатор (120, 180, 270) |
Индикатор (термометр) |
Индикатор уровня |
Линейный индикатор |
Сегментный индикатор |
Емкость уровень |
Цифровой и матричный индикатор |
4. Тренд
Графическая компонента для представления информации о канале в виде графика (тренда):
5. Изображения
Графические компоненты для добавления к схеме рисунков.
Название компоненты | Тип
Изображение | рисунок
Динамическое изображение | рисунок с привязкой к каналу
Мультиизображение | рисунок с привязкой к фиксированным значениям канала
6. Дополнительные компоненты
Эти две компоненты служат для отображения текущего времени и даты.
7. Компоненты управления
Служат для ввода специфической информации (слайдер, поле ввода, кнопки) и запуска внешних приложений и мнемосхем.
Название компоненты | Тип
Слайдер | Считывает в канал цифровую информацию из текущего положения слайдера по нажатию кнопки
Цифровой задатчик | Задает в канале численное значение в поле ввода по нажатию кнопки
Запись фиксированного значения | Записывает в канал фиксированное значение по нажатию кнопки
Кнопки | 3 типа переключателей для обслуживания логической функциональности мнемосхем
Запуск внешнего приложения | запускает внешнюю программу
Открытие мнемосхемы | открывает мнемосхему

Содержание раздела Типы графических компонент

Привязка графических компонент к каналу
Фигуры
Трубы
Индикаторы
Тренды
Изображения
Дополнительные компоненты
Компоненты управления


Раздел: Привязка графических компонент к каналу

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Привязка графических компонент к каналу
← Пред
След →

Привязка графических компонент к каналу

Графические компоненты мнемосхемы могут быть привязаны к текущему значению канала ОРС сервера. В зависимости от значения канала и границ уставок свойства отображения компоненты на мнемосхеме динамически меняются.
Связь компоненты с каналом устанавливается включением флага привязки к каналу в панели свойств компоненты:
Привязка графических компонент к каналу

Флаг привязки к каналу

1. Флаг привязки к каналу
Данный флаг присутствует в панели свойств большинства графических компонент. Компонентами без возможности привязки к каналу являются:
  • трубы
  • изображение (статическое)
  • компоненты даты и времени
  • компоненты запуска приложения и открытия мнемосхемы

Имя связанного канала

2. Имя связанного канала
После установки флага привязки становится доступным поле выбора имени активного канала ОРС сервера, а также настройки отображения компоненты в зависимости от выхода значения канала за границы уставок. Выбрать имя канала можно в списке доступных каналов. Список открывается после щелчка мышью в поле имени канала и нажатия появившейся кнопки со значком списка:

Настройки привязки к каналу

3. Настройки привязки к каналу
Настройки привязки к каналу определяют режим визуального преставления текущего значения в канале. Графические компоненты автоматически изменяют свои параметры, если текущее значение выходит за границы уставок или находится в пределах нормы. Дополнительно можно установить режим мигания в случае выхода значения за границы уставок. Для различных типов графических компонент настройки привязки к каналу определяются соответствующим образом.


Раздел: Фигуры

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Фигуры
← Пред
След →

Фигуры

Фигуры — это графические примитивы, служащие для визуального представления внешних устройств ОРС сервера. Цвет заливки фигур можно привязать к значению канала.

Палитра фигур

В палитре фигур можно выделить две группы:
1. Фигуры с текстом
2. Фигуры без текста

Фигуры с текстом

  • прямоугольники
  • емкости
  • круг

Фигуры без текста

  • клапаны
  • стрелки

Содержание раздела Фигуры

Общие свойства фигур
Свойства фигур с текстом


Раздел: Общие свойства фигур

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Фигуры
  • Общие свойства фигур
← Пред
След →

Общие свойства фигур

Общие свойства фигур

Цвет линии

1. Цвет линии
Определяет цвет контура фигуры

Цвет градиента 1

2. Цвет градиента 1
Если фигура не привязана к каналу, то для нее можно определить градиентную заливку из двух цветов.

Цвет градиента 2

3. Цвет градиента 2
Задает второй цвет градиента заливки фигуры.

Толщина линии

4. Толщина линии
Задает толщину линии контура фигуры.

Вид градиента

5. Вид градиента
Задает вид градиента, переходящего от цвета 1 к цвету 2:
  • вертикальный сверху вниз
  • горизонтальный слева направо
  • центрированный по горизонтали
  • центрированный по вертикали

Привязка к каналу

6. Привязка к каналу
Флаг привязки к каналу служит для настроек отображения фигуры, связанной со значением канала. Панель свойств фигуры, связанной с каналом, выглядит иначе:
Для связанной фигуры отсутствуют свойства градиента, но добавляются дополнительные свойства:
1. флаг установки прозрачного фона
2. имя связанного канала
3. настройки параметров компоненты в зависимости от текущего значения канала
Значения канала выше или ниже уставки или в пределах нормы можно выделить изменением цвета заливки фигуры. Выход значения канала за границы уставок дополнительно можно обозначить режимом мигания фигуры.


Раздел: Свойства фигур с текстом

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Фигуры
  • Свойства фигур с текстом
← Пред
След →

Свойства фигур с текстом

Для фигур с текстом в панели свойств можно настроить параметры отображения текста:
Свойства фигур с текстом

Установка прозрачного фона

1. Установка прозрачного фона
Если установлен данный флаг, то цвет заливки фигуры становится прозрачным.

Флаг видимости текста

2. Флаг видимости текста
Флаг включения видимости текста фигуры.

Настройка шрифта

3. Настройка шрифта
Выбор шрифта для текста фигуры. После наведения курсора в область поля выбора шрифта, на нем появляется кнопка вызова стандартного диалога настроек шрифта:

Строка текста для отображения

4. Строка текста для отображения
Поле ввода строки текста, которая отображается в центральной области фигуры:

Флаг привязки к каналу

Если фигура с текстом привязана к каналу, в ее панели свойств помимо общих настроек привязки к каналу появляется дополнительный флаг Показать переменную:
Если этот флаг включен, то текст фигуры дополнительно отображает значение переменной канала.


Раздел: Трубы

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Трубы
← Пред
След →

Трубы

Трубы служат для графического отображения взаимосвязей внешних устройств ОРС сервера. Настройки труб нельзя привязать к значению канала.

Палитра труб

Включает в себя несколько типов труб:
  • вертикальный/горизонтальный отрезок трубы
  • угольники 1-4
  • тройники 1-4
  • крестовина

Свойства труб

Свойства труб содержат две настройки для задания цветов градиента заливки:


Раздел: Индикаторы

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
← Пред
След →

Индикаторы

Индикаторы — это графические компоненты для динамического отображения текущего значения канала. Палитра индикаторов выглядит следующим образом:

Текстовые индикаторы

Отображают значение канала в виде строки. При выходе канала за границы уставок цвет заливки и текст строки могут изменяться.

Секторные индикаторы

Все эти индикаторы отображают текущее значение канала на условной шкале. Шкала определяет уровень значения канала и разделена на три сектора, в зависимости от границ уставок канала (минимум, максимум и норма).
Шкала может быть линейной и радиальной (круговой).

Индикатор термометр

3. Индикатор термометр
Служит для отображения значения канала в виде термометра.

Цифровой и матричный индикатор

Отображают значение канала в виде цифрового счетчика или строки.

Содержание раздела Индикаторы

Текстовые индикаторы
Секторные индикаторы
Индикатор-термометр
Цифровой и матричный индикатор
simp@miniscada.com
http://miniscada.com/allproducts/simp-light


Раздел: Текстовые индикаторы

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Текстовые индикаторы
← Пред
След →

Текстовые индикаторы

Текстовые индикаторы отображают информацию о текущем значении канала в виде строки текста. Значение текста и цвет заливки могут быть привязаны к текущему значению канала.

Панель

Панель с приподнятой рамкой (тип 1).

Текст

Текст с рамкой.

Динамический текст

Динамический текст устанавливается по отдельно взятым значениям переменной канала.

Содержание раздела Текстовые индикаторы

Панель
Текст
Динамический текст
simp@miniscada.com
http://miniscada.com/allproducts/simp-light


Раздел: Панель

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Текстовые индикаторы
  • Панель
← Пред
След →

Панель

Панель — это текстовый индикатор, отображающий текст в виде панели с рамкой. Вид текстовой строки определяется текущим значением канала.

Вид рамки

Поле выбора рамки. Выпадающий список содержит следующие опции:
1. без рамки
2. приподнятая рамка (тип рамки 1)
3. утопленная рамка (тип рамки 2)
4. обычная рамка (тип рамки 3)
5. выделенная рамка (тип рамки 4)

Настройка шрифта

Поле выбора шрифта. По нажатию кнопки открывается стандартный диалог настроек шрифта.

Флаг видимости переменной

Флаг видимости переменной доступен только в режиме привязки компоненты к каналу.

Флаг привязки к каналу

Если флаг привязки к каналу выключен, то цвет заливки и текст индикатора не зависят от значения канала.

Настройки привязки к каналу

Заданный цвет заливки панели и текст отображают выход значения канала за границы уставок и возврат в установленные пределы. Дополнительно можно определить режим мигания при выходе значения канала за границы уставок.


Раздел: Текст

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Текстовые индикаторы
  • Текст
← Пред
След →

Текст

Текст — это графическая компонента для отображения строки текста. Свойства цвета линии и толщины линии задают цвет и толщину рамки вокруг текста строки.

Цвет линии

Цвет рамки, ограничивающей текст.

Толщина линии рамки

Толщина рамки, ограничивающей текст. Если толщина линии равна 0, то рамка отсутствует.
Остальные свойства компоненты текста аналогичны свойствам компоненты Панель.


Раздел: Динамический текст

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Текстовые индикаторы
  • Динамический текст
← Пред
След →

Динамический текст

Динамический текст служит для привязки значения отображаемой строки к конкретным фиксированным значениям канала. Если динамический текст не привязан к каналу, то его свойства совпадают со свойствами компоненты Текст. Если у динамического текста установлен флаг привязки к каналу, то его панель свойств принимает следующий вид:

Список связанных переменных

Данное поле содержит список пар "значение - текст" для установки строки динамического текста при достижении каналом конкретного значения. В панели свойств отображается количество связанных значений канала. Список значений для просмотра и редактирования открывается по нажатию кнопки в правой части поля:

Значение

Поле для ввода численного значения в канале, которое будет связано с определенной строкой текста.

Текст

Поле для ввода строки текста, отвечающей заданному значению в канале.

Кнопки сохранения или отмены изменений

Нажмите Ок для сохранения изменений в списке связанных пар переменных канала и текста.


Раздел: Секторные индикаторы

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Секторные индикаторы
← Пред
След →

Секторные индикаторы

Секторные индикаторы — это графические компоненты, которые фиксируют текущее значение канала на шкале значений.
При установленной привязке к каналу, цвета шкалы значений канала устанавливаются в зависимости от границ уставок. К секторным индикаторам относятся:
  • радиальные (3 типа)
  • линейные (2 типа)
  • индикаторы уровня (6 типов)

Радиальные индикаторы

3 типа радиальных индикаторов

Линейные индикаторы

2 типа линейных индикаторов

Индикаторы уровня

6 типов индикаторов уровня

Содержание раздела Секторные индикаторы

Общие свойства секторных индикаторов
Радиальный индикатор
Линейный индикатор
Индикаторы уровня
simp@miniscada.com
http://miniscada.com/allproducts/simp-light


Раздел: Общие свойства секторных индикаторов

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Секторные индикаторы
  • Общие свойства секторных индикаторов
← Пред
След →

Общие свойства секторных индикаторов

Основные настройки секторных индикаторов включают в себя установки цвета секторов шкалы для привязки к граничным значениям канала. Все секторные индикаторы обладают следующим набором свойств:
Общие свойства секторных индикаторов

Цвет фона

Поле установки цвета фона индикатора.

Флаг видимости рамки

Служит для отображения рамки вокруг индикатора.

Флаг отображения секторов

При установке флага шкала индикатора отображает сектора в соответствии с границами уставок связанного канала.

Сектор максимум

Устанавливает цвет части шкалы для отображения значений выше установленных допустимых границ в связанном канале.

Сектор норм.

Устанавливает цвет части шкалы для отображения допустимых значений в канале.

Сектор минимум

Устанавливает цвет части шкалы для отображения значений ниже установленных допустимых границ в связанном канале.

Флаг прозрачности фона

Служит для установки видимости фона компоненты.

Привязка к каналу

Флаг привязки к каналу

Имя канала

Имя активного канала ОРС сервера. Выбирается из списка доступных каналов. Свойство доступно только при включенном флаге привязки к каналу.

Режим мигания

Режим мигания включается при выходе значения канала за границы уставок. Свойство доступно только при включенном флаге привязки к каналу.


Раздел: Радиальный индикатор

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Секторные индикаторы
  • Радиальный индикатор
← Пред
След →

Радиальный индикатор

Радиальный индикатор отображает текущие значения канала в виде цифровой шкалы, расположенной на секторе круга (120, 180, 270 градусов). К свойствам радиального индикатора относятся:

Шаг шкалы

Поле установки цифрового значения единичного шага шкалы.

Настройка шрифта

Открывает стандартное диалоговое окно настроек шрифта.

Цвет шкалы

Устанавливает цвет отображаемой шкалы значений канала.
Остальные свойства радиального индикатора описаны в разделе Общих свойств секторных индикаторов .


Раздел: Линейный индикатор

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Секторные индикаторы
  • Линейный индикатор
← Пред
След →

Линейный индикатор

Линейный индикатор отображает текущие значения канала в виде вертикальной или горизонтальной цифровой шкалы. К свойствам линейного индикатора относятся:

Шаг шкалы

Задает величину единичного шага шкалы индикатора.
Остальные свойства линейного индикатора описаны в разделе Общих свойств секторных индикаторов .


Раздел: Индикаторы уровня

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Секторные индикаторы
  • Индикаторы уровня
← Пред
След →

Индикаторы уровня

Индикаторы уровня графически отображают уровень значения в канале. К этому типу относятся 6 видов индикаторов:
  • индикатор уровня (вертикальный и горизонтальный)
  • сегментный индикатор (вертикальный и горизонтальный)
  • емкость и емкость в виде конуса
К свойствам индикаторов уровня относятся:

Цвет заливки

Устанавливает цвет фона индикатора уровня. В режиме привязки к каналу это свойство недоступно.
Остальные свойства индикаторов уровня описаны в разделе Общих свойств секторных индикаторов .


Раздел: Индикатор-термометр

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Индикатор-термометр
← Пред
След →

Индикатор-термометр

Индикатор-термометр служит для отображения температурного режима в канале.

Индикатор-термометр

Цвет фона

Устанавливает цвет фона термометра.

Рамка

Флаг видимости рамки.

Прозрачный фон

Флаг установки прозрачности фона.

Привязка к каналу

Флаг установки привязки к каналу .

Имя канала

Имя связанного канала. Выбирается из списка доступных каналов. Свойство доступно только в случае включения флага привязки к каналу.


Раздел: Цифровой и матричный индикатор

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Цифровой и матричный индикатор
← Пред
След →

Цифровой и матричный индикатор

Цифровой индикатор отображает информацию о канале в виде цифрового табло со значением канала. Матричный индикатор может дополнительно отображать текст в виде табло:
Цифровой и матричный индикаторы отличаются лишь наличием у матричного индикатора свойства Текст, определяющего строку для отображения в табло.

Содержание раздела Цифровой и матричный индикатор

Свойства цифрового индикатора
Свойства матричного индикатора


Раздел: Свойства цифрового индикатора

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Цифровой и матричный индикатор
  • Свойства цифрового индикатора
← Пред
След →

Свойства цифрового индикатора

Свойства цифрового индикатора

Цвет фона

Выбор цвета фона индикатора

Цвет 1

Выбор цвета для отображения цифр (активных сегментов) табло

Цвет 2

Выбор цвета для отображения неактивных сегментов табло

Количество символов

Длина табло в символах.

Рамка

Флаг включения рамки.

Вид индикатора

Задает один из трех видов отображения сегментов индикатора (узкие, средние и широкие).

Привязка к каналу

Флаг привязки к каналу

Имя канала

Имя связанного канала. Доступно только после включения флага привязки к каналу.


Раздел: Свойства матричного индикатора

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Индикаторы
  • Цифровой и матричный индикатор
  • Свойства матричного индикатора
← Пред
След →

Свойства матричного индикатора

Свойства матричного индикатора

Текст индикатора

1. Текст индикатора
Задает строку текста, которая отображается матричным индикатором. Свойство доступно только в случае отключения привязки компоненты к каналу.
Остальные свойства матричного индикатора совпадают со свойствами цифрового индикатора.


Раздел: Тренды

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Тренды
← Пред
След →

Тренды

Тренд — это графическая компонента, отображающая значение в канале в виде графика. Вертикальная шкала служит для измерения значения канала в момент времени, соответствующий значению горизонтальной шкалы. Подробнее об использовании и настройках трендов можно прочитать в разделе Просмотр трендов. Редактор мнемосхем содержит только один вид тренда в палитре компонент:

Временная шкала

Для настройки временной шкалы см. раздел Настройка временной шкалы тренда.

Шкала значений

На этой шкале отмечаются текущие значения каналов тренда. Для настройки шкалы значений см. раздел Настройка шкалы значений тренда.

Содержание раздела Тренды

Свойства тренда


Раздел: Свойства тренда

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Тренды
  • Свойства тренда
← Пред
След →

Свойства тренда

Цвет 1

Устанавливает цвет фона поля тренда.

Цвет 2

Устанавливает цвет фона компоненты.

Флаг видимости заголовка

Если данный флаг включен, то в верхней части тренда отображается строка заголовка

Заголовок

Определяет строку заголовка тренда.

Легенда

Флаг отображения легенды. Легенда не пуста, если тренд привязан к значению каналов. В легенде отражается информация о соответствии цветов на графике тренда именам связанных каналов:

Флаг привязки к каналу

По нажатию кнопки в правой части данного поля открывается диалоговое окно настроек тренда, позволяющее настроить параметры привязки тренда к значениям активных каналов.

Содержание раздела Свойства тренда

Настройка каналов тренда
Настройка временной шкалы тренда
Настройка шкалы значений тренда


Раздел: Настройка каналов тренда

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Тренды
  • Свойства тренда
  • Настройка каналов тренда
← Пред
След →

Настройка каналов тренда

Настройка каналов тренда осуществляется во вкладке Каналы диалогового окна настроек тренда. Для открытия этого диалогового окна необходимо перейти к свойствам тренда, выбрать свойство привязки к каналу и нажать на кнопку в левой части поля.
Настройка каналов тренда

Список активных каналов

Для выбора канала с привязкой к тренду необходимо включить соответствующий флаг напротив имени канала.

Цвет пера

Выбор цвета графика значения канала на тренде.

Ширина пера

Настройка ширины линии графика канала на тренде.

Ось Y

Если с трендом связано несколько каналов, то для каждого из них имеется возможность настроить собственную шкалу значений. Настройки шкалы значений находятся во вкладке Ось Y диалогового окна настроек тренда.

Флаг включения автоматической шкалы

При включении данного флага шкала значений автоматически настраивается на диапазон значений в канале. При этом все текущие значения в канале попадают в зону видимости графика тренда. Максимум и минимум шкалы определяется соответственно максимальному и минимальному значению в текущем канале.


Раздел: Настройка временной шкалы тренда

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Тренды
  • Свойства тренда
  • Настройка временной шкалы тренда
← Пред
След →

Настройка временной шкалы тренда

Настройка временной шкалы тренда осуществляется во вкладке Ось X диалогового окна настроек тренда. Для открытия этого диалогового окна необходимо перейти к свойствам тренда, выбрать свойство привязки к каналу и нажать на кнопку в левой части поля.
Настройка временной шкалы тренда

Настройка интервала шкалы

Задает длину временного промежутка, соответствующего шкале X.

Шаг шкалы

Настройка единичного шага шкалы.

Количество дополнительных делений

Количество дополнительных делений шкалы, отображаемых внутри единичного отрезка (шага).

Цвет шкалы

Задает цвет временной шкалы.

Цвет шрифта

Задает цвет шрифта значений временной шкалы.

Формат

Формат отображения временных значений шкалы.


Раздел: Настройка шкалы значений тренда

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Тренды
  • Свойства тренда
  • Настройка шкалы значений тренда
← Пред
След →

Настройка шкалы значений тренда

Различным связанным каналам могут соответствовать различные шкалы значений на тренде. Настройка шкалы значений тренда осуществляется во вкладке Ось Y диалогового окна настроек тренда. Для открытия этого диалогового окна необходимо перейти к свойствам тренда, выбрать свойство привязки к каналу и нажать на кнопку в левой части поля.
Настройка шкалы значений тренда

Список шкал значений каналов

У тренда имеется возможность настроить несколько видов шкалы значений для нескольких связанных каналов. Просмотреть имеющиеся шкалы можно в данном списке. Поле Ось Y в закладке Каналы служит для связывания шкалы значений и канала.

Кнопки добавления и удаления шкал

Кнопки служат для управления списком имеющихся шкал значений.

Настройки текущей шкалы значений

3. Настройки текущей шкалы значений
Настройки шкалы значений отображаются на тренде следующим образом:


Раздел: Изображения

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Изображения
← Пред
След →

Изображения

Изображения — это компоненты для отображения графических файлов. Палитра изображений выглядит следующим образом:

Изображение

Загружает графический файл из стандартной коллекции Редактора мнемосхем или из ресурсов пользователя. Компонента не связывается с каналом.

Динамическое изображение

Загружает графический файл из стандартной коллекции Редактора мнемосхем или из ресурсов пользователя, который может быть связан со значением канала в зависимости от границ уставок.

Мульти изображение

Загружает графический файл из стандартной коллекции Редактора мнемосхем или из ресурсов пользователя. Файл изображения связан с конкретным значением в текущем канале.

Содержание раздела Изображения

Свойства изображения
Свойства динамического изображения
Свойства мульти изображения


Раздел: Свойства изображения

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Изображения
  • Свойства изображения
← Пред
След →

Свойства изображения

Компонента изображения не связывается со значением канала. Ее панель свойств выглядит следующим образом:

Файл изображения

Поле содержит выпадающий список:
Для задания изображения необходимо определить ссылку на графический объект из стандартной коллекции Редактора мнемосхем или внешний файл из пользовательских ресурсов.

Флаг прозрачности фона

Устанавливает режим видимости фона для компоненты


Раздел: Свойства динамического изображения

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Изображения
  • Свойства динамического изображения
← Пред
След →

Свойства динамического изображения

Динамическое изображение может быть связано со значением канала. При этом изображение может изменяться в зависимости от границ уставок канала.
Свойства динамического изображения

Флаг прозрачности фона

Устанавливает режим видимости фона изображения.

Растянуть

Флаг включает автоматическое растягивание подключенного изображения, так чтобы оно занимало всю область компоненты.

Привязка к каналу

Флаг служит для включения привязки к каналу. При включении данного флага разворачиваются опции настройки изображения в зависимости от попадания значения канала в установленные границы.

Имя канала

Поле служит для выбора имени канала, связанного с изображением.

Настройки привязки изображения

Для связанного динамического изображения имеются три опции настройки рисунка:
  • значение выше уставки
  • значение норма
  • значение ниже уставки
Для каждого из этих интервалов значений канала может быть настроен свой рисунок, выбранный из имеющихся файлов изображений. См. Настройка файла изображения .
Дополнительно можно установить режим мигания компоненты, если значение канала вышло за границы уставок.


Раздел: Свойства мульти изображения

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Изображения
  • Свойства мульти изображения
← Пред
След →

Свойства мульти изображения

Свойства мульти изображения

Привязка к каналу

Флаг служит для включения привязки к каналу. При включении данного флага становится доступным свойство Переменные для установления связи изображений с конкретными значениями в канале.

Флаг прозрачности фона

Устанавливает режим видимости фона изображения.

Переменные

Поле содержит список пар "значение - изображение" для установления связи фиксированных значений в канале и графических файлов. Для настройки переменных служит диалоговое окно, которое открывается по нажатию на кнопку в правом углу поля свойства:
Для связывания значения канала с изображением необходимо:
1. Задать численное значение в поле 1.
2. Выбрать файл изображения в стандартном диалоге открытия файла, который открывается по нажатию кнопки 2.
3. Использовать кнопки добавления и удаления 3 для редактирования списка.
4. Нажать Ок по завершении работы для сохранения изменений.

Имя связанного канала

Поле служит для выбора имени канала, связанного с изображением.


Раздел: Дополнительные компоненты

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Дополнительные компоненты
← Пред
След →

Дополнительные компоненты

Дополнительные компоненты — это компоненты для отображения текущей даты и времени. Данные компоненты не связываются со значениями в каналах:
Компоненты даты и времени обладают следующим набором свойств:

Цвет панели

Задает цвет панели, на которой отображается дата или время.

Шрифт

Открывает стандартный диалог настройки шрифта

Вид рамки

Рамка может отсутствовать или быть одного из 4 видов (см. Вид рамки)


Раздел: Компоненты управления

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Компоненты управления
← Пред
След →

Компоненты управления

Компоненты управления служат для выполнения пользовательских действий, связанных с функциональностью мнемосхемы. Палитра компонент управления выглядит следующим образом:

Компоненты-переключатели

Переключатели (кнопки) служат для задания логики функционирования мнемосхемы.

Компоненты запуска

2. Компоненты запуска
Служат для запуска внешних приложений или открытия мнемосхем.

Компоненты для записи значений в канал

3. Компоненты для записи значений в канал
Служат для считывания фиксированных значений (по слайдеру, из значения поля или заданных заранее) и записи их в канал.

Содержание раздела Компоненты управления

Компоненты для записи значений в канал
Переключатели
Запуск приложений и мнемосхем


Раздел: Компоненты для записи значений в канал

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Компоненты управления
  • Компоненты для записи значений в канал
← Пред
След →

Компоненты для записи значений в канал

Редактор мнемосхем позволяет пользователю записывать значения в текущие доступные каналы ОРС сервера. Каналы, открытые для записи, служат для управления функционированием технологического процесса. Записать значение можно с помощью трех компонент:
  • Установки слайдера в некоторое значение и нажатия кнопки записи на слайдере
  • Ввода значения в текстовое поле цифрового задатчика и нажатия кнопки записи
  • Считывания заранее заданного значения по нажатию кнопки записи фиксированного значения
Общим свойством всех компонент записи является флаг привязки к каналу (с указанием имени) и флаг подтверждения записи.
Внимание! Запись в текущий активный канал ОРС сервера производится в режиме запущенной мнемосхемы в программе Монитор SIMP Light . Если переменная канала открыта только для чтения (установлен соответствующий ОРС атрибут), то запись значения в канал не произойдет, и Монитор выдаст предупреждающее сообщение:

Содержание раздела Компоненты для записи значений в канал

Свойства кнопки записи значения
Свойства слайдера
Свойства цифрового задатчика


Раздел: Свойства кнопки записи значения

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Компоненты управления
  • Компоненты для записи значений в канал
  • Свойства кнопки записи значения
← Пред
След →

Свойства кнопки записи значения

Свойства кнопки записи значения

Текст

Текст на кнопке записи.

Шрифт

Открывает диалоговое окно настроек шрифта текста на кнопке записи.

Значение

Фиксированное численное значение для записи в канал.

Флаг подтверждения записи

Если данный флаг установлен, то перед записью значения в канал при изменении параметров мнемосхемы Монитор запрашивает у пользователя подтверждение:
При нажатии Yes данные записываются в канал.

Привязка к каналу

Флаг включения привязки к каналу. При включении данного флага становится видимым поле имени связанного канала, которое можно выбрать из списка доступных каналов.


Раздел: Свойства слайдера

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Компоненты управления
  • Компоненты для записи значений в канал
  • Свойства слайдера
← Пред
След →

Свойства слайдера

Максимум и минимум значений

Границы шкалы слайдера.

Подтверждение записи

Если данный флаг установлен, то перед записью значения в канал при изменении параметров мнемосхемы Монитор запрашивает у пользователя подтверждение (см. Подтверждение записи ).

Привязка к каналу

Флаг включения привязки к каналу. При включении данного флага становится видимым поле имени связанного канала, которое можно выбрать из списка доступных каналов.

Имя канала

Имя активного канала ОРС сервера. Выбирается из списка доступных каналов. Свойство доступно только при включенном флаге привязки к каналу.


Раздел: Свойства цифрового задатчика

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Компоненты управления
  • Компоненты для записи значений в канал
  • Свойства цифрового задатчика
← Пред
След →

Свойства цифрового задатчика

Свойства цифрового задатчика

Цвет фона

Устанавливает цвет фона текстового поля.

Подтверждение записи

Если данный флаг установлен, то перед записью значения в канал при изменении параметров мнемосхемы Монитор запрашивает у пользователя подтверждение (см. Подтверждение записи ).

Привязка к каналу

Флаг включения привязки к каналу. При включении данного флага становится видимым поле имени связанного канала, которое можно выбрать из списка доступных каналов.


Раздел: Переключатели

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Компоненты управления
  • Переключатели
← Пред
След →

Переключатели

Переключатели служат для записи значений в канал по заданной схеме (алгоритму). Переключатели позволяют логически связать компоненты мнемосхемы и задать настройки управления функционированием технологического процесса.
  • Кнопка (тип "без фиксации"): записывает одно значение по нажатию и другое — по отжатию (можно настроить задержку сигнала).
  • Кнопка (тип "тумблер"): пишет в канал только значение 0 или 1 и сохраняет его до следующего переключения.
  • Кнопка (тип "триггер"): пишет в канал только значение 0 или 1, инвертирует его и сохраняет до следующего переключения.
Все переключатели выглядят на мнемосхеме как обычные кнопки с текстом.

Содержание раздела Переключатели

Свойства кнопки без фиксации
Свойства триггера и тумблера


Раздел: Свойства кнопки без фиксации

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Компоненты управления
  • Переключатели
  • Свойства кнопки без фиксации
← Пред
След →

Свойства кнопки без фиксации

Свойства кнопки без фиксации

Шрифт

Открывает диалоговое окно настроек шрифта надписи на кнопке.

Флаг включения авторазмера

Если данный флаг отключен, то отображение кнопки не изменяется при изменении ее размера.

Привязка к каналу

Флаг включения привязки к каналу. Если данный флаг включен, то для кнопки становятся видимыми дополнительные настройки в привязке к каналу: имя канала и настройки состояния "отжато" и "нажато".

Имя канала

Имя активного канала ОРС сервера. Выбирается из списка доступных каналов. Свойство доступно только при включенном флаге привязки к каналу.

Свойства состояния "отжато"

5. Свойства состояния "отжато"
Свойства кнопки в отжатом состоянии:
  • Изображение на кнопке (путь к графическому файлу)
  • Текст на кнопке
  • Значение, записываемое в канал в момент отжатия кнопки

Свойства состояния "нажато"

6. Свойства состояния "нажато"
Настройки кнопки в нажатом состоянии:
  • Изображение на кнопке (путь к графическому файлу)
  • Текст на кнопке
  • Значение, записываемое в канал в момент нажатия кнопки
  • Задержка записи значения в канал после момента нажатия кнопки


Раздел: Свойства триггера и тумблера

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Компоненты управления
  • Переключатели
  • Свойства триггера и тумблера
← Пред
След →

Свойства триггера и тумблера

Настройки для переключателей типа "триггер" и "тумблер" совпадают. Обе компоненты записывают в текущий связанный канал только логические значения (0 и 1). Главное отличие данных компонент состоит в их логике функционирования:
1. Если в переключателе сохранено значение 0 (выключен):
  • при нажатии тумблера в канал запишется 0, и состояние переключателя будет установлено в 1 (включено).
  • при нажатии триггера в канал запишется 1, и состояние переключателя будет установлено в 1 (сброшено).
2. Если в переключателе сохранено значение 1 (включен):
  • при нажатии тумблера в канал запишется 1, и состояние переключателя будет установлено в 0 (сброшено).
  • при нажатии триггера в канал запишется 0, и состояние переключателя будет установлено в 0 (включено).
Тумблер сохраняет значение в канале и инвертирует его, триггер инвертирует значение в канале и сохраняет его. Панель свойств триггера и тумблера аналогична панели свойств кнопки без фиксации (у данных переключателей отсутствует свойство задержки сигнала).
Свойства триггера и тумблера
simp@miniscada.com
http://miniscada.com/allproducts/simp-light


Раздел: Запуск приложений и мнемосхем

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Типы графических компонент
  • Компоненты управления
  • Запуск приложений и мнемосхем
← Пред
След →

Запуск приложений и мнемосхем

Компоненты запуска приложений и открытия мнемосхем выглядят как обычные кнопки, по нажатию которых выполняется указанное действие. Эти компоненты не связаны со значениями каналов, и их панель свойств определяет текст на кнопке, цвет кнопки и путь к приложению (мнемосхеме):
Запуск приложений и мнемосхем

Текст

Текст на кнопке запуска (открытия).

Шрифт

Открывает стандартное диалоговое окно выбора шрифта для текста на кнопке.

Приложение (мнемосхема)

Путь к файлу приложения (мнемосхемы). Запускает стандартное диалоговое окно открытия файла.


Раздел: Добавление и настройка компонент мнемосхемы

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Добавление и настройка компонент мнемосхемы
← Пред
След →

Добавление и настройка компонент мнемосхемы

Для добавления графической компоненты выберите ее в палитре компонент и перетащите мышью в поле редактирования мнемосхемы. Компонента появится в поле и получит фокус управления:
Добавление и настройка компонент мнемосхемы

Редактор свойств компоненты

1. Редактор свойств компоненты
Свойства текущей компоненты настраиваются в редакторе свойств. Панель редактора свойств открывается по нажатию кнопки со стрелкой вниз.

Текущая активная компонента

2. Текущая активная компонента
Компонента, которая получила фокус, выделена на мнемосхеме. Ее положение и размер можно менять с помощью мыши и клавиатурных стрелок.

Строка состояния

3. Строка состояния
Строка состояния содержит информацию о текущей компоненте:
  • положение верхнего левого угла относительно сетки координат
  • ширину и высоту
  • тип графической компоненты и порядковый номер


Раздел: Копирование компонент мнемосхемы

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Копирование компонент мнемосхемы
← Пред
След →

Копирование компонент мнемосхемы

Для копирования выделенной графической компоненты выберите пункты меню Правка -> Копировать, Правка -> Вставить или нажмите сочетания клавиш Ctrl+C и Сtrl+V. Новая компонента будет добавлена к мнемосхеме и получит фокус управления, ее свойства будут также скопированы.
Копирование компонент мнемосхемы
simp@miniscada.com
http://miniscada.com/allproducts/simp-light


Раздел: Группировка компонент

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Группировка компонент
← Пред
След →

Группировка компонент

Группировка — это привязка нескольких графических компонент к одному фокусу управления. Сгруппированные компоненты всегда получают фокус одновременно, поэтому их положение относительно друг друга не меняется при перетаскивании мышью и настройке дизайна схемы.
Для настройки группировки:
1. Выделите несколько компонент (более одной).
2. Выберите пункт меню Правка -> Сгруппировать.
3. Группировка добавлена. Всякий раз при выделении одной из сгруппированных компонент все компоненты группы получают фокус совместно:
4. Для отключения группировки выделенной группы компонент выберите пункт меню Правка -> Разгруппировать.


Раздел: Выравнивание компонент

  • Редактор мнемосхем SIMP Light
  • Работа с графическими компонентами
  • Выравнивание компонент
← Пред
След →

Выравнивание компонент

Опции выравнивания положения компонент мнемосхемы находятся в меню Правка. Для задания выравнивания выделенных компонент необходимо:
1. Разгруппировать компоненты, если они сгруппированы.
2. Выбрать в меню Правка один из режимов выравнивания:
  • по левому или правому краю: левый (правый) край группы компонент определяется как наименьшая (наибольшая) горизонтальная координата, выбранная из координат их текущих положений:
  • по верхнему или нижнему краю: верхний (нижний) край группы компонент определяется как наибольшая (наименьшая) вертикальная координата, выбранная из координат их текущих положений:
  • центрировать по вертикали и горизонтали: центральная ось вертикального (горизонтального) выравнивания компонент определяется как среднее их нижнего и верхнего (левого и правого) края:
3. Выровненные компоненты становятся группой и получают совместный фокус при выделении.


Раздел: Запуск режима эмуляции работы мнемосхемы

  • Редактор мнемосхем SIMP Light
  • Запуск режима эмуляции работы мнемосхемы
← Пред
След →

Запуск режима эмуляции работы мнемосхемы

Режим эмуляции служит для тестирования работоспособности и корректности настроек мнемосхемы. Режим эмуляции позволяет записать в канал фиксированное значение или включить генератор значений. В режиме генератора на все каналы, связанные с компонентами мнемосхемы, подается один и тот же сигнал в заданных пределах. Текущее значение увеличивается с шагом 1, начиная с указанного минимума, до тех пор пока значение в канале не достигнет указанного максимума. Затем значение начинает уменьшаться с шагом 1 и так далее. Такой сигнал называется пилообразным.
Диалоговое окно настроек и запуска режима эмуляции открывается из меню Настройка -> Запустить режим эмуляции или нажатием комбинации клавиш Ctrl+F9. Панель компонент мнемосхемы при этом скрывается.
Запуск режима эмуляции работы мнемосхемы

Максимальное значение

1. Максимальное значение
Задает верхнюю границу пилообразного сигнала, подаваемого в канал.

Минимальное значение

2. Минимальное значение
Задает нижнюю границу пилообразного сигнала, подаваемого в канал.

Флаг использования генератора

3. Флаг использования генератора
Данный флаг включает пилообразный генератор значений канала (увеличение от минимума до максимума, а затем уменьшение и т.д.). Если флаг отключен, то в канал можно записать фиксированное значение в поле записи значения.

Качество переменной (GOOD)

4. Качество переменной (GOOD)
Флаг качества переменной. Если данный флаг установлен, то графическое отображение компоненты мнемосхемы указывает на наличие ошибки в текущем состоянии подаваемого сигнала (атрибут OPC Quality Code).

Текущее значение для записи

5. Текущее значение для записи
Если включен флаг использования генератора, то данное поле отображает текущее значение, записанное в канал. Состояние всех компонент мнемосхемы соответствует генерируемым значениям:
Поле может служить для записи фиксированного значения в канал, если флаг использования генератора отключен. В этом случае поле становится доступным для редактирования. После нажатия кнопки Записать, записанное значение отображается на компонентах мнемосхемы:

Кнопка записи

6. Кнопка записи
Кнопка служит для записи фиксированного значения в канал. Данная кнопка доступна только в случае отключенного флага использования генератора значений.


Раздел: Запуск других модулей

  • Редактор мнемосхем SIMP Light
  • Запуск других модулей
← Пред
След →

Запуск других модулей

Редактор мнемосхем позволяет пользователю переключаться между модулями и запускать Монитор и Редактор каналов. Для этого служит меню Настройка:
Запуск других модулей
Редактор каналов позволяет настроить свойства каналов параллельно с их привязкой к графическим компонентам. Монитор отслеживает работу мнемосхемы в режиме реального времени.


Раздел: Модуль просмотра графиков SIMP Light

  • Модуль просмотра графиков SIMP Light
← Пред
След →

Модуль просмотра графиков SIMP Light

Модуль просмотра графиков SIMP Light позволяет просматривать графики значений каналов ОРС сервера. Наиболее существенными элементами Модуля просмотра графиков являются:
1. Просмотр графиков
Основной функцией Модуля просмотра графиков является просмотр графиков. Модуль позволяет настроить различные режимы отображения графиков для активных каналов и их групп.
2. Работа с данными графиков
Дополнительно, данные графиков можно экспортировать в стандартные форматы баз данных и распечатать.

Содержание раздела Модуль просмотра графиков SIMP Light

Просмотр графиков
Работа с данными графиков


Раздел: Просмотр графиков

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
← Пред
След →

Просмотр графиков

Главной функцией Модуля просмотра графиков является просмотр графического отображения текущих значений канала. При открытии приложения автоматически выбирается текущая дата для просмотра и отображается список активных каналов ОРС сервера.
Внимание! Модуль просмотра графиков отображает только те значения каналов, которые были зарегистрированы в Мониторе . Для просмотра текущих значений необходимо запустить Монитор SIMP Light , который передает данные о значениях каналов в Модуль просмотра графиков.

Календарь

Календарь служит для выбора даты просмотра графика. Графики соответствуют значениям активных каналов Монитора. Пользователь может просмотреть архивные графики. Чтобы выбрать месяц или год для просмотра графиков, необходимо кликнуть мышью в его области. Календарь отобразит список месяцев/лет для выбора даты просмотра:
Календарь можно свернуть нажатием на стрелку в правой верхней части окна.

Список активных каналов

2. Список активных каналов
Список активных каналов служит для выбора каналов, значения которых отображаются на графике. В момент выбора канала из списка его график в окне просмотра обновляется.

Окно просмотра графиков

В данном окне отрисовываются графики значений каналов в режиме реального времени. Цвета графиков соответствуют цветам выбранных каналов.
Внимание! Окно просмотра графиков обновляется только по выбору значения канала в списке активных каналов и при пролистывании страниц графика. Для просмотра графиков значений в режиме реального времени необходимо использовать режим тренда в Мониторе SIMP Light . Тренд автоматически обновляет график при поступлении данных из канала.

Меню настройки отображения графиков

Данное меню служит для настройки отображения графиков. Пользователь может:
  1. Настраивать параметры отображения графика , такие как шкала, цвет и толщина пера.
  2. Задавать режим увеличения для просмотра увеличенного изображения графика.
  3. Задавать режим курсора для просмотра значений графика в фиксированные моменты времени.
  4. Листать график по временной шкале.
Данные настройки аналогичны настройкам просмотра и отображения трендов в Мониторе.

Главное меню

В данное меню включены настройки обработки данных графиков:
  • Экспорт в базу данных или таблицу
  • Калькулятор расходов
  • Печать данных
  • Просмотр журнала тревог

Шкала значений

Шкала значений каналов. Для удобства просмотра шкалу можно пролистывать и масштабировать .

Содержание раздела Просмотр графиков

Выбор активных каналов для просмотра
Пролистывание и масштабирование шкалы значений
Режим увеличения
Режим курсора
Настройки отображения графиков


Раздел: Выбор активных каналов для просмотра

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
  • Выбор активных каналов для просмотра
← Пред
След →

Выбор активных каналов для просмотра

Панель выбора каналов находится в левой нижней части главного окна Модуля просмотра графиков и отображает список активных каналов ОРС сервера. В данной панели пользователь может:
  • добавлять и удалять активные каналы для просмотра графиков
  • редактировать цвет, ширину пера и шкалу отображения каналов
  • создавать и удалять группы каналов для отображения на графиках
Выбор активных каналов для просмотра

Флаг включения просмотра графика

После включения данного флага, график, соответствующий значению канала, отображается в поле просмотра графиков.

Иконка цвета

Иконка отображает цвет графика канала. Для настройки цвета и толщины пера дважды кликните в области иконки. Откроется диалоговое окно настройки цвета и толщины пера графика выбранного канала.

Кнопки управления группами каналов

3. Кнопки управления группами каналов
Модуль просмотра графиков позволяет пользователю настроить группы каналов, графики которых отображаются совместно.

Содержание раздела Выбор активных каналов для просмотра

Настройка цвета, толщины и шкалы графика канала
Настройка групп каналов


Раздел: Настройка цвета, толщины и шкалы графика канала

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
  • Выбор активных каналов для просмотра
  • Настройка цвета, толщины и шкалы графика канала
← Пред
След →

Настройка цвета, толщины и шкалы графика канала

Модуль просмотра графиков позволяет пользователю настроить цвета и ширину линии отображаемых графиков. Для выбора цвета необходимо дважды кликнуть на иконку цвета у соответствующего имени в списке активных каналов . Откроется диалоговое окно настроек цвета:
Настройка цвета, толщины и шкалы графика канала

Палитра цветов

Палитра цветов служит для выбора и задания цвета графика канала.

Ширина пера

Данное поле служит для настройки ширины линии графика текущего канала. По умолчанию при выборе активного канала ширина пера всегда равна 1. Если в данном поле выбрано другое значение, то график канала будет отрисован пером с другой толщиной:
Ширина пера не сохраняется при отключении и включении отображения графика канала.

Общая Y-шкала

Флаг включения использования общей Y-шкалы. Если данный флаг отключен, то в окне просмотра графиков появляется дополнительная шкала значений для данного графика, которую можно пролистывать независимо от основной шкалы:

Кнопки сохранения или отмены изменений

По завершении редактирования нажмите Ок для сохранения изменений.


Раздел: Настройка групп каналов

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
  • Выбор активных каналов для просмотра
  • Настройка групп каналов
← Пред
След →

Настройка групп каналов

Активные каналы, выбранные для просмотра, можно объединять в группы. Графики группы открываются для просмотра совместно. Для настройки групп каналов служат кнопки в нижней части панели списка каналов:
Настройка групп каналов

Добавление группы

1. Добавление группы
Для добавления новой группы необходимо выбрать каналы (отметить флаги включения просмотра графиков) и нажать кнопку добавления группы. Откроется диалоговое окно, запрашивающее имя новой группы:
После ввода имени нажмите Ок. Новая группа будет добавлена к списку групп каналов.

Удаление группы

2. Удаление группы
Выберите группу каналов для удаления и нажмите данную кнопку.

Сброс выбора

3. Сброс выбора
Кнопка сбрасывает флаг включения просмотра графиков для всех каналов.

Группы каналов

Список добавленных групп каналов. Окно просмотра графиков каналов отображает только графики выбранной группы.


Раздел: Пролистывание и масштабирование шкалы значений

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
  • Пролистывание и масштабирование шкалы значений
← Пред
След →

Пролистывание и масштабирование шкалы значений

Шкала значений каналов настраивается динамически. Во-первых, при наведении курсора мыши в область шкалы с нажатой левой кнопкой ее можно пролистывать:
Пролистывание и масштабирование шкалы значений
Во-вторых, шкалу можно масштабировать. Для этого необходимо перевести курсор мыши в область шкалы и использовать колесо прокрутки мыши при нажатой клавише Ctrl:


Раздел: Режим увеличения

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
  • Режим увеличения
← Пред
След →

Режим увеличения

Для детального просмотра графика канала можно настроить режим увеличения:
1. Нажмите кнопку включения увеличения в меню настроек просмотра графиков (значок лупы).
2. У курсора мыши появится иконка режима увеличения (белый прямоугольник). Перейдите в окно просмотра графика, нажмите правую кнопку мыши и, не отпуская ее, выделите область графика для увеличения. После отпускания кнопки мыши окно отобразит увеличенный фрагмент графика:
3. В увеличенном фрагменте графика можно снова выбрать область для увеличения. Для завершения работы с режимом увеличения снова нажмите кнопку включения увеличения. В окне отображения графиков будет восстановлен нормальный режим просмотра.


Раздел: Режим курсора

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
  • Режим курсора
← Пред
След →

Режим курсора

Режим курсора позволяет просмотреть информацию о точном значении канала в данный момент времени. Для включения режима курсора нажмите кнопку курсора данных в меню настроек просмотра графиков :

Кнопка включения курсора

1. Кнопка включения курсора
По нажатию кнопки в области просмотра графиков отображается курсор данных. Повторное нажатие кнопки отключает курсор.

Курсор данных

Вертикальная синяя линия, рядом с которой отображается значение канала в указанный момент времени. С помощью мыши курсор можно передвигать.


Раздел: Настройки отображения графиков

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
  • Настройки отображения графиков
← Пред
След →

Настройки отображения графиков

Диалоговое окно настроек отображения графиков вызывается по нажатию кнопки Настроить график в меню настроек графиков.
Настройки отображения графиков

Кнопка настройки просмотра графиков

1. Кнопка настройки просмотра графиков
Вызывает диалоговое окно со следующими настройками:
  • для временной шкалы: начало отсчета, шаг и длину интервала, количество дополнительных делений шкалы и формат отображения
  • для шкалы данных: шаг шкалы, дополнительные деления и линии в окне просмотра.
  • общие настройки: цвет пера, фона и линий, ширину пера, легенду и отступы печати.

Содержание раздела Настройки отображения графиков

Шкала времени
Шкала данных
Общие настройки


Раздел: Шкала времени

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
  • Настройки отображения графиков
  • Шкала времени
← Пред
След →

Шкала времени

Настройки шкалы времени находятся в первой закладке диалогового окна настроек отображения графика.

Начало шкалы

Задает начало отсчета временного промежутка (интервала) шкалы.

Желаемый шаг шкалы

Задает длину единичного отрезка (шага) шкалы.

Интервал шкалы

Задает длину временного промежутка (интервала), отображаемого в окне просмотра графиков.

Количество дополнительных делений

Определяет количество дополнительных делений шкалы внутри единичного отрезка (шага).

Формат

Формат отображения текущего времени.

Показать доп. линии

Флаг включения видимости дополнительных линий в области графика. Вертикальные линии соответствуют дополнительным делениям временной шкалы и отмечаются пунктиром.


Раздел: Шкала данных

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
  • Настройки отображения графиков
  • Шкала данных
← Пред
След →

Шкала данных

Желаемый шаг шкалы

Длина единичного отрезка шкалы.

Количество доп. делений

Количество делений внутри единичного отрезка (шага).

Показать доп. линии

Флаг включения видимости дополнительных линий в области графика. Горизонтальные линии соответствуют дополнительным делениям шкалы и отмечаются пунктиром.


Раздел: Общие настройки

  • Модуль просмотра графиков SIMP Light
  • Просмотр графиков
  • Настройки отображения графиков
  • Общие настройки
← Пред
След →

Общие настройки

Цвет пера по умолчанию

Цвет графиков по умолчанию. График выбранного канала отрисовывается пером данного цвета.

Ширина пера по умолчанию

Ширина линии графиков по умолчанию. График выбранного канала отрисовывается пером данной ширины.

Цвет фона

Цвет фона окна отображения графиков.

Цвет сетки

Цвет, которым отображаются линии разметки в окне просмотра графиков.

Показать легенду

Флаг включения отображения легенды с цветами и именами каналов. Дополнительно в легенде отображается последнее зафиксированное значение канала в отображаемом временном промежутке:

Настройки отступов печати

Задает отступы страниц при печати графика.


Раздел: Работа с данными графиков

  • Модуль просмотра графиков SIMP Light
  • Работа с данными графиков
← Пред
След →

Работа с данными графиков

Модуль просмотра графиков предоставляет следующие возможности дополнительной обработки данных графиков:
  • использование калькулятора
  • вызов и просмотр журнала тревог: просмотр данных о выходе каналов за границы уставок и квитировании значений
  • экспорт базы данных: сохранение данных графиков на диске
  • печать данных: вывод данных графиков на печать
Опции обработки данных графиков находятся в главном меню Модуля в верхней части главного окна:
Работа с данными графиков

Содержание раздела Работа с данными графиков

Использование калькулятора расходов
Просмотр журнала тревог
Экспорт базы данных
Печать данных


Раздел: Использование калькулятора расходов

  • Модуль просмотра графиков SIMP Light
  • Работа с данными графиков
  • Использование калькулятора расходов
← Пред
След →

Использование калькулятора расходов

Калькулятор расходов рассчитывает значения выбранных каналов в выбранный промежуток времени. На данный момент эта функция отключена.
Использование калькулятора расходов
simp@miniscada.com
http://miniscada.com/allproducts/simp-light


Раздел: Просмотр журнала тревог

  • Модуль просмотра графиков SIMP Light
  • Работа с данными графиков
  • Просмотр журнала тревог
← Пред
След →

Просмотр журнала тревог

Окно журнала тревог открывается по нажатию кнопки Журнал тревог в главном меню Модуля просмотра графиков:
Просмотр журнала тревог
Журнал тревог содержит информацию о выходе значений канала за границы установленных значений и квитировании сигналов. Подробнее о работе с Журналом тревог можно прочитать в разделе Работа с журналом оповещений.


Раздел: Экспорт базы данных

  • Модуль просмотра графиков SIMP Light
  • Работа с данными графиков
  • Экспорт базы данных
← Пред
След →

Экспорт базы данных

Базу данных значений каналов можно экспортировать в формат таблицы Excel или CSV. Данные о значениях выбранных каналов в течение выбранного промежутка времени будут сохранены в виде файла на диске. Для экспорта данных нажмите кнопку Экспорт в главном меню Модуля просмотра графиков. Откроется диалоговое окно настроек экспорта:
Экспорт базы данных

Начальная дата

Выбор начальной даты временного промежутка экспортируемых данных.

Конечная дата

Выбор конечной даты временного промежутка экспортируемых данных.

Список доступных каналов

Каналы, значения которых будут экспортированы, необходимо отметить в данном списке.

Настроить

Нажатие кнопки открывает диалоговое окно настроек экспорта.

Экспорт

Нажатие кнопки экспорт создает файл базы данных на диске с данными о выбранных значениях канала за указанный промежуток времени (с начальной даты по конечную).

Содержание раздела Экспорт базы данных

Настройки экспорта


Раздел: Настройки экспорта

  • Модуль просмотра графиков SIMP Light
  • Работа с данными графиков
  • Экспорт базы данных
  • Настройки экспорта
← Пред
След →

Настройки экспорта

Диалоговое окно настроек экспорта служит для настройки пути, формата и частоты сохранения данных. Данное окно открывается по нажатию кнопки Настроить окна экспорта базы данных:

Папка

Путь к папке, где будет сохранен файл базы данных на диске.

Формат файла

Допускается сохранение базы данных в одном из двух форматов: CSV и Excel.

Желаемый шаг экспорта

Задает значение шага, с которым значение канала записывается в базу данных (на рисунке указан шаг величиной в 1 час, что означает запись одного значения в каждый час, начиная с момента отсчета).

Сохранение изменений

Нажмите Ок для сохранения изменений.


Раздел: Печать данных

  • Модуль просмотра графиков SIMP Light
  • Работа с данными графиков
  • Печать данных
← Пред
След →

Печать данных

Данные графиков можно распечатать. Стандартное окно настроек печати открывается по нажатию кнопки Печать в главном меню Модуля просмотра графиков.
Дополнительно можно настроить размер отступов страниц при печати графиков.


Раздел: Менеджер проектов SIMP Light

  • Менеджер проектов SIMP Light
← Пред
След →

Менеджер проектов SIMP Light

Менеджер проектов SIMP Light предназначен для управления пользовательскими проектами SIMP Light.
Проект — это совокупность мнемосхем технологических процессов и настроек каналов ОРС сервера. Наиболее существенными чертами Менеджера проектов являются:
1. Работа с проектами
Менеджер проектов позволяет управлять активностью проектов, создавать резервные копии, экспортировать и импортировать данные проектов.
2. Запуск других модулей

Содержание раздела Менеджер проектов SIMP Light

Главное окно Менеджера проектов
Работа с проектами
Запуск других модулей


Раздел: Главное окно Менеджера проектов

  • Менеджер проектов SIMP Light
  • Главное окно Менеджера проектов
← Пред
След →

Главное окно Менеджера проектов

Главное окно Менеджера проектов содержит рабочее меню и список имеющихся проектов:
Главное окно Менеджера проектов

Список проектов

1. Список проектов
Список проектов состоит из трех папок:
1. Текущий проект — активный рабочий проект, данные которого используются при настройке и функционировании остальных модулей SIMP Light.
2. Другие проекты — папка нерабочих проектов.
3. Резервные копии — папка резервных копий текущего проекта. Проекты в данной папке хранятся по дате и времени создания копии.

Меню Менеджера проектов

Меню Менеджера проектов состоит из следующих команд:
  • Проект — команды работы с проектами
  • Запустить — команды запуска других модулей
  • Справка — запуск справки


Раздел: Работа с проектами

  • Менеджер проектов SIMP Light
  • Работа с проектами
← Пред
След →

Работа с проектами

Все функции Менеджера проектов находятся в команде Проект главного меню приложения:
Работа с проектами
Все данные команды могут быть выполнены и при вызове контекстного меню (правая кнопка мыши) для отдельных проектов. При работе с проектами обычно необходимо закрыть другие приложения SIMP Light.

Содержание раздела Работа с проектами

Создание проекта
Удаление проекта
Создание резервной копии проекта
Переименование проекта
Смена активности проекта
Импорт и экспорт проектов


Раздел: Создание проекта

  • Менеджер проектов SIMP Light
  • Работа с проектами
  • Создание проекта
← Пред
След →

Создание проекта

Для создания нового пустого проекта:
1. Выберите команду меню Проект -> Создать. Все приложения SIMP Light должны быть закрыты при создании нового проекта.
2. Менеджер проектов запустит диалоговое окно с запросом о создании нового проекта:
3. После этого будет автоматически создана резервная копия текущего рабочего проекта (перемещение данных в папку резервных копий займет несколько секунд) :
4. Затем новый пустой проект будет создан и станет активным:

Новый проект

Новый проект автоматически становится активным.

Предыдущий активный проект

Предыдущий активный проект автоматически перемещен в папку резервных копий.


Раздел: Удаление проекта

  • Менеджер проектов SIMP Light
  • Работа с проектами
  • Удаление проекта
← Пред
След →

Удаление проекта

Для удаления проекта выберите команду меню Проект -> Удалить или нажмите клавишу Del. Менеджер проектов запросит подтверждение удаления проекта перед удалением всех файлов проекта:
Все приложения SIMP Light должны быть закрыты, если удаляется текущий активный проект. Активный проект после удаления автоматически заменится на пустой с таким же именем.
Внимание! Пустой активный проект не может быть удален.


Раздел: Создание резервной копии проекта

  • Менеджер проектов SIMP Light
  • Работа с проектами
  • Создание резервной копии проекта
← Пред
След →

Создание резервной копии проекта

Резервная копия автоматически создается при смене активного проекта. Создание резервной копии гарантирует сохранность данных текущего проекта. Для неактивного проекта резервное копирование не предусмотрено. Для создания резервной копии текущего активного проекта:
1. Выберите команду меню Проект -> Создать резервную копию для текущего активного проекта. Внимание! Для пустого проекта нельзя создать резервную копию.
Копия проекта в текущий момент времени будет добавлена в папку резервных копий:
Создание резервной копии проекта

Папка резервных копий

1. Папка резервных копий
В папке резервных копий архивные проекты хранятся по дате и времени сохранения.


Раздел: Переименование проекта

  • Менеджер проектов SIMP Light
  • Работа с проектами
  • Переименование проекта
← Пред
След →

Переименование проекта

Для переименования выбранного проекта выберите команду меню Проект -> Переименовать или нажмите клавишу F2. Менеджер проектов запросит новое имя проекта:
Введите новое имя и нажмите Ok.


Раздел: Смена активности проекта

  • Менеджер проектов SIMP Light
  • Работа с проектами
  • Смена активности проекта
← Пред
След →

Смена активности проекта

Текущий активный проект используется другими приложениями SIMP Light для работы с каналами ОРС сервера и мнемосхемами технологических процессов. Все приложения SIMP Light работают только с одним активным проектом одновременно. Для смены активного проекта выберите команду меню Проект -> Сделать активным или дважды кликните мышью на имени канала.
Перед сменой активного проекта все остальные приложения SIMP Light должны быть закрыты. В обратном случае Менеджер проектов выдаст предупреждение о наличии открытых приложений и не сменит активность канала. Если приложения закрыты, то программа запросит подтверждение смены активности канала:
Смена активности проекта
После нажатия кнопки OK выбранный проект станет активным, то есть станет отображаться в папке Текущий проект. Все приложения SIMP Light будут использовать настройки и данные нового активного проекта. Предыдущий активный проект будет перемещен в папку Другие проекты.


Раздел: Импорт и экспорт проектов

  • Менеджер проектов SIMP Light
  • Работа с проектами
  • Импорт и экспорт проектов
← Пред
След →

Импорт и экспорт проектов

Все проекты хранятся в виде файлов с расширением *.slz. Для сохранения данных проекта на диске выберите команду меню Проект -> Экспортировать проект. Откроется диалоговое окно выбора папки для экспорта:
Импорт и экспорт проектов
По завершении экспортирования Менеджер проектов предложит открыть папку с проектом в проводнике.
Для импорта текущего проекта из файла *.slz выберите команду меню Проект -> Импортировать проект. Появится стандартное диалоговое окно открытия файла. Затем Менеджер проектов запросит подтверждение смены текущего проекта, и импортированный проект станет активным.
Предыдущий активный проект будет перемещен в папку Другие проекты.


Раздел: Запуск других модулей

  • Менеджер проектов SIMP Light
  • Запуск других модулей
← Пред
След →

Запуск других модулей

Все приложения SIMP Light запускаются из Менеджера проектов. Для запуска одного из модулей выберите команду меню Запустить и выберите модуль:
Запуск других модулей
Дополнительно Редактор каналов текущего проекта запускается по двойному щелчку мыши на имени активного канала.


Раздел: Использование скриптов

  • Использование скриптов
← Пред
След →

Использование скриптов

Редактор скриптов служит для создания и внесения изменений в программные скрипты виртуальных каналов:

Окно редактирования скрипта

1. Окно редактирования скрипта
Текст скрипта на выбранном языке программирования создается и редактируется в данном окне. В окно редактирования встроены следующие функции:
  • Возможность копирования и вставки текста в/из буфера обмена.
  • Возможность вызова внутренних функций для выполнения процедур, связанных с чтением и записью в канал. Список функций можно просмотреть по нажатию Ctrl+Space.
  • Включенное автозаполнение имени канала и внутренней функции.

Вывод информации об ошибках

В данном поле выводится информация об ошибках компиляции. Ошибки, связанные с обращением к каналам, игнорируются.

Список активных каналов

3. Список активных каналов
Список содержит имена всех активных каналов для удобства обращения к необходимому для работы имени канала.

Рабочее меню скрипта

Редактор скриптов позволяет провести выполнение скрипта в тестовом режиме, а также компиляцию для проверки и выявления синтаксических ошибок.
По завершении работы с Редактором скриптов нажмите Ок для сохранения изменений.

Содержание раздела Использование скриптов

Использование API SimpLight
Внутренние функции для работы со скриптами
Выполнение скрипта
Компиляция скрипта


Раздел: Использование API SimpLight

  • Использование скриптов
  • Использование API SimpLight
← Пред
След →

Использование API SimpLight

Внутренние функции пакета SIMP Light (API) служат для следующих операций обеспечения доступа к каналам и мнемосхемам:
  • чтение и запись значения канала в переменную скрипта
  • чтение и запись значения канала в текстовый файл
  • сохранение значения канала в базу данных проекта
  • установление заданного свойства виртуального канала
  • побитовое чтение и запись в канал
  • открытие и закрытие мнемосхем и т.д.
Список внутренних функций можно просмотреть, нажав Ctrl+Space с курсором в области окна редактирования скрипта. Имена каналов передаются внутренним функциям в качестве строковых переменных.
Использование API SimpLight
simp@miniscada.com
http://miniscada.com/allproducts/simp-light


Раздел: Внутренние функции для работы со скриптами

  • Использование скриптов
  • Внутренние функции для работы со скриптами
← Пред
След →

Внутренние функции для работы со скриптами

  1. Команды работы с каналами.
  2. Команды побитовой обработки чисел.
  3. Команды для работы с текстовыми файлами.
  4. Команды для вывода текстовых сообщений.
  5. Команды для работы с мнемосхемами.
  6. Работа с EXCEL
  7. Работа с базой данных
  8. Работа с аламами
  9. Разное
Скачать все примеры одним файлом.

Содержание раздела Внутренние функции для работы со скриптами

Команды работы с каналами(тегами)
Команды побитовой обработки чисел
Команды для работы с текстовыми файлами
Команды для вывода текстовых сообщений
Команды для работы с мнемосхемами
Работа с EXCEL
Работа с базой данных значений
Команды работы с глобальными переменными
Работа с алармами (выход за уставки, аварии)
Разное


Раздел: Команды работы с каналами(тегами)

  • Использование скриптов
  • Внутренние функции для работы со скриптами
  • Команды работы с каналами(тегами)
← Пред
След →

Команды работы с каналами(тегами)

Название функции
Переменные
Действие
Пример
Function
ReadValue (АName: String): Variant
АName — имя канала
Возвращает текущее значение канала AName.
Пример вызова:
val:=ReadValue("tag1");
СКАЧАТЬ
Function
WriteValue (АName: String; Val: Variant): boolean
АName — имя канала
Val — значение для записи в канал
Записывает значение Val в канал AName.
Возвращает true, если запись успешна, и false, если произошла ошибка записи.
Пример вызова:
WriteValue("Tag1", 1234);
Function
GetQuality (АName: String): Word
АName — имя канала
Возвращает атрибут OPC Quality Code , содержащий информацию о текущем состоянии ОРС тега AName. Наиболее часто используемыми атрибутами являются:
Значения OPC Quality Code:
Код | Значение
0 | ошибка канала
4 | ошибка конфигурации
8 | нет соединения
12 | ошибка устройства
16 | ошибка датчика
24 | ошибка связи
32 | идет инициализация
192 | нет ошибок, нормальная работа
216 | локальная перегрузка
Пример вызова:
code:=GetQuality("tag1");
Function
GetTimeStamp(AName: String): TDateTime
(AName: String): TDateTime
Возвращает метку времени, когда были последние изменения у канала.
---
Пример вызова:
LastWrite:=GetTimeStamp("tag1");
Procedure
SetVirtualChannelQuality (AName: String; AQuality: Word)
АName — имя канала
AQuality — атрибут OPC Quality Code , содержащий информацию о текущем состоянии ОРС тега AName (см. таблицу с кодами выше)
Устанавливает атрибут качества AQuality виртуальному каналу AName.
при пересчёте равльного - проецирование качества реального
Значения OPC Quality Code:
Код | Значение
0 | ошибка канала
4 | ошибка конфигурации
8 | нет соединения
12 | ошибка устройства
16 | ошибка датчика
24 | ошибка связи
32 | идет инициализация
192 | нет ошибок, нормальная работа
216 | локальная перегрузка
Пример вызова:
SetVirtualChannelQuality("tag1", 24);
СКАЧАТЬ
Function WriteVirtualChannel (AName: String; AValue: Variant; ATimeStamp: TDateTime; AQuality: Word): Boolean
AName -имя канала
AValue - значение канала
ATimeStamp - временная метка
AQuality - качество канала
Запись в БД произвольного значения вирт.канала с произвольным значением метки времени и качества.
Применяется, если нужно записывать значения не по таймеру, а по наступлению определённого события.
Пример вызова:
WriteVirtualChannel("v_tag1", 34, now() ,192);


Раздел: Команды побитовой обработки чисел

  • Использование скриптов
  • Внутренние функции для работы со скриптами
  • Команды побитовой обработки чисел
← Пред
След →

Команды побитовой обработки чисел

Команды этой группы позволят считывать и изменять состояние отдельных бит в целочисленных значениях.
Поддерживаются типы данных БАЙТ(BYTE - 8 BIT) и СЛОВО (WORD- 16 BIT).
Биты считаются справо-налево
BYTE - 7 6 5 4 3 2 1 0
WORD - 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
Часто применяется для "распаковки" дискретных сигналов. На контроллере дискретные сигналы записываются в 1 байт, а в СКАДА системе раскладываются на 8 бит.
Название функции | Переменные | Действие | Пример
Function GetBit (Value: Variant; Bit: integer): Byte | Value: число Bit: индекс бита (диапазон от 0 до 15) | Возвращает значение бита с индексом Bit в переменной Value. Пример вызова: bit1Value:=GetBit(255,0); bit1Value:=GetBit(ReadValue("tag1"),0); | СКАЧАТЬ
Function SetOnBit (var Value: Variant; Bit: integer): Boolean | Value: число Bit: индекс бита, устанавливаемого в 1 (диапазон от 0 до 15) | Возвращает true, если запись успешна, и false, если произошла ошибка записи. Пример вызова: WriteValue("tag1", SetOnBit());
Function SetOffBit (var Value: Variant; Bit: integer): Boolean | Value: число Bit: индекс бита, устанавливаемого в 0 (диапазон от 0 до 15) | Возвращает true, если запись успешна, и false, если произошла ошибка записи. Пример вызова: WriteValue("tag1", SetOffBit());


Раздел: Команды для работы с текстовыми файлами

  • Использование скриптов
  • Внутренние функции для работы со скриптами
  • Команды для работы с текстовыми файлами
← Пред
След →

Команды для работы с текстовыми файлами

Функци позволяют работать с текстовыми файлами. Записывать и считывать из них различную информацию.
Название функции | Переменные | Действие | Пример
Function SaveToTxtFile (АFileName: string; Str: string): Boolean | АFileName — путь к файлу Str — строка для записи | Записывает строковое значение Str в текстовый файл AFileName. Возвращает true, если запись успешна, и false, если произошла ошибка записи. Запись происходит последовательно, строчка за строчкой. Пример вызова: SaveToTxtFile("c:\receipt.txt", "123,33,44,555"); | СКАЧАТЬ
Function LoadFromTxtFile (АFileName: string; index: Integer): string | АFileName — путь к файлу index — номер строки | Возвращает строку с номером index из текстового файла AFileName. Строки нумеруются с индекса 0. Пример вызова: LoadFromTxtFile("c:\receipt.txt",0);
Function GetFileStrCount (АFileName: string): Integer | АFileName — путь к файлу | Возвращает количество строк в текстовом файле AFileName. Пример вызова: count:=GetFileStrCount("c:\receipt.txt");


Раздел: Команды для вывода текстовых сообщений

  • Использование скриптов
  • Внутренние функции для работы со скриптами
  • Команды для вывода текстовых сообщений
← Пред
След →

Команды для вывода текстовых сообщений

Название процедуры | Переменные | Действие | Пример
Procedure ShowMessageBox (ACaption, AMsg: Variant; AIconIndex: Byte) | ACaption — заголовок сообщения AMsg — текст сообщения AIconIndex — индекс иконки | Показывает текстовое сообщение AMsg с заголовком ACaption и иконкой AIconIndex: 0: без иконки 1: ICONINFORMATION (информация) 2: ICONQUESTION (вопрос) 3: ICONWARNING (предупреждение) 4: ICONSTOP (стоп) Пример вызова: ShowMessageBox("Заголовок", "Тест", 3); | СКАЧАТЬ
Procedure ShowMessage (AMsg: Variant) | AMsg — текст сообщения | Показывает текстовое сообщение AMsg. Пример вызова: ShowMessage("TEXT");


Раздел: Команды для работы с мнемосхемами

  • Использование скриптов
  • Внутренние функции для работы со скриптами
  • Команды для работы с мнемосхемами
← Пред
След →

Команды для работы с мнемосхемами

Название процедуры | Переменные | Действие | Пример
Procedure OpenMnemo (AName: string) | AName — имя мнемосхемы | Открывает просмотр мнемосхемы AName. Пример вызова: OpenMnemo("Узел варки"); | СКАЧАТЬ
Procedure OpenMnemoToPos (AName: string; X: Integer; Y: Integer) | AName — имя мнемосхемы X, Y — координаты верхнего левого угла видимой части мнемосхемы. | Открывает просмотр мнемосхемы AName начиная с координат (X, Y). Пример вызова: OpenMnemoToPos("Регулятор", 20,300);
Procedure CloseMnemo (AName: string) | AName — имя мнемосхемы | Закрывает мнемосхему AName. Пример вызова: CloseMnemo("Регулятор");
Procedure CloseAllMnemo |  | Закрывает все текущие открытые мнемосхемы. Пример вызова: CloseAllMnemo;
Function CheckOpenMnemo(AName: String): Boolean | AName — имя мнемосхемы | Функция вернёт True если мнемосхема AName открыта в «Мониторе», если мнемосхема не открыта функция возвратит False. Пример вызова: if CheckOpenMnemo("Регулятор") then CloseMnemo("Регулятор") else OpenMnemoToPos("Регулятор", 20,300);


Раздел: Работа с EXCEL

  • Использование скриптов
  • Внутренние функции для работы со скриптами
  • Работа с EXCEL
← Пред
След →

Работа с EXCEL

Функции позволяют формировать произвольные отчёты в EXCEL.
Название функции | Переменные | Действие | Пример
Procedure OpenTemplate(FileName: string) | FileName: string | Открыть шаблон Excel (после выполнения функция возвращает код ошибки: 0 – ошибок нет, 1 - файл не найден, 2 - Excel не установлен, 3 - ошибка инициализации COM, 9 - неизвестная ошибка) | Пример1 Пример2
Procedure CreateTemplate:word |  | Создаёт новый документ Excel (после выполнения функция возвращает код ошибки: 0 – ошибок нет, 1 - файл не найден, 2 - Excel не установлен, 3 - ошибка инициализации COM, 9 - неизвестная ошибка)
Procedure PasteBand(Name: string) | Name: string | Добавляет на лист нужный нам бэнд (бэнд - это одна или несколько строк, имеющих в первой ячейке одно и тоже имя).
Procedure SetValue(VarName: string; Value: Variant) | VarName: string; Value: Variant | Находит в последнем установленном бэнде переменную с именем VarName и заменяет это имя на его значение Value. Этот метод можно вызывать столько раз, сколько предполагается различных переменных в нужном бэнде.
Procedure Show(mode:boolean) |  | Показать сформированный отчет в Excel.
Procedure Close |  | Закрыть Excel.
Procedure Save(AName: string) | AName: string | Сохранить документ Excel
Property Cell |  | Доступ к ячейкам документа Excel


Раздел: Работа с базой данных значений

  • Использование скриптов
  • Внутренние функции для работы со скриптами
  • Работа с базой данных значений
← Пред
След →

Работа с базой данных значений

Функции позволяют считать данные из дазы данных СИМП за указанный промежуток времени.
Применяются для:
1. Расчёт расхода
2. Время работы оборудования
Название функции | Переменные | Действие | Пример
Function StreamReadFromDatabase(ABegin, AEnd: TDateTime; AChannel: string; OutputStream: TStream): Word | ABegin - начальная дата AEnd - конечная дата AChannel - имя канала OutputStream - поток приемник возвращаемое значение : DB_READ_OK = 0; DB_DATE_ERROR = 1; DB_MEMORY_OVERFLOW = 2; DB_CHANNEL_NOTFOUND = 3; | Считывает данные из БД во внутренний поток. | Пример1 Пример2
Function GetValueFromStream(const AStream: TStream; var ATimestamp: TDateTime; var AValue: Double): Boolean | AStream - прочитанный ранее функцией StreamReadFromDatabase поток ATimestamp - считанная временная метка AValue - считанное значение | Функция будет считывать последовательно записи из считанного потока (возвращаемое значение - true), пока не будет достигнуть конец потока (возвращаемое значение - false).
Function GetCountRecordToStream(const AStream: TStream): Integer | AStream - прочитанный ранее функцией StreamReadFromDatabase поток возвращаемое значение - кол-во записей в потоке. | Считывает кол-во записей в потоке.
Function SaveValueToDB (АName: String): Boolean | АName — имя канала | Сохраняет текущее значение канала AName в базу данных проекта с текущей меткой времени и текущим значением. Возвращает true, если запись успешна, и false, если произошла ошибка записи. Можно снять галку Сохранять и сохранять данные канала по событю. | СКАЧАТЬ
Function SaveChannelToDB (AName: String; ATimestamp: TDateTime; AValue: Variant): Boolean | AName: String; ATimestamp: TDateTime; AValue: Variant | Сохраняет текущее значение канала AName в базу данных проекта с возможностью установить НУЖНУЮ метку времени и НУЖНОЕ значение.


Раздел: Команды работы с глобальными переменными

  • Использование скриптов
  • Внутренние функции для работы со скриптами
  • Команды работы с глобальными переменными
← Пред
След →

Команды работы с глобальными переменными

Глобальные переменные могут использоваться для
1. Передавать данные между скриптами
2. Особенность - сохраняют свои значения даже после выключения программы и перезагрузки ПК.
Название функции | Переменные | Действие | Пример
Procedure SetGlobalVar(const AVarName: string; AVarValue: Variant; AStored: Boolean = False); | AVarName - имя глобальной переменной AVarValue - значение переменной AStored - true - сохранять на диск/ false - не сохранять на диск | Записывает глобальную переменную Пример вызова: SetGlobalVar("Счётчик1", counter1, true); | СКАЧАТЬ
Function GetGlobalVar(const AVarName: string): Variant; | AVarName - имя глобальной переменной возвращаемое значение - значение переменной | Считывает глобальную переменную Пример вызова: GetGlobalVar("Счётчик1");


Раздел: Работа с алармами (выход за уставки, аварии)

  • Использование скриптов
  • Внутренние функции для работы со скриптами
  • Работа с алармами (выход за уставки, аварии)
← Пред
След →

Работа с алармами (выход за уставки, аварии)

Название функции | Переменные | Действие | Пример
Procedure AddToLog(Text); |  | Добавляет произвольный текст в таблицу алармов Пример вызова: AddToLog("Включена вентиляция"); | СКАЧАТЬ
Function GetActiveAlarm: Boolean | result:Boolean | Если есть хотя бы один канал за зоной уставок, то result = true, иначе result = false Пример вызова: if GetActiveAlarm then Alarm:=1 else Alarm:=0;
Function GetAlarmStatus(AName: String): Byte | AName: String Result:Byte | Функция позволяет получить статус тревоги у канала AName, результатом работы функции будет код статуса: Result: 0-Переменная ниже уставки (Аналоговый канал) 1-Переменная в рабочей зоне (Аналоговый канал) 2-Переменная выше уставки (Аналоговый канал) 3-Сигнал тревоги квитирован пользователем (Аналоговый/ Дискретный канал) 4-Переменная Вкл. (Дискретный канал) 5-Переменная Откл. (Дискретный канал) Пример вызова: status:=GetAlarmStatus("TAG1");
Procedure ResetAllAlarm |  | Перезагружает(сбрасывает) все текущие тревоги (оповещения Монитора). Пример вызова: ResetAllAlarm;


Раздел: Разное

  • Использование скриптов
  • Внутренние функции для работы со скриптами
  • Разное
← Пред
След →

Разное

Название функции
Переменные
Действие
Пример
Function
AsFirstRun : Boolean
Function
Initialization:Boolean
Возвращает true, если скрипт запущен в первый раз, и false, если запуск — повторный.
Пример вызова:
if AsFirstRun then value:=0;
Procedure
Delay (AInterval: Integer)
AInterval - интервал, задаётся в миллисекундах,
1000 мс = 1 сек
"Замораживает" скрипт на указанный интервал.
Пример вызова:
Delay(1000); //"заморозит" выполнение скрипта на 1 секунду
задержка отправки уставки, например
СКАЧАТЬ
ПРИМЕР
Function
SetComboBox(AName: String; AComboBox: String; AText: string; APosition: Word): Boolean
AName-имя мнемосхемы,
AComboBox-имя комбобокса на мнемосхеме
AText: - строки записываються в одну строку через запятую,или точку с запятой, пример: “ строка1,строка2,строка3”
APosition – индекс строки которую выбрать по
умолчанию (индексы строк начинаются с 0)
Заполнить выпадающий список AComboBox (имя выпадающего списка на мнемосхеме), на мнемосхеме AName
Пример вызова:
SetComboBox (‘MyMnemo’, ‘MyComboBox’, ‘Рецепт1,Рецепт2, Рецепт3’, 0);
СКАЧАТЬ
ПРИМЕР
Function
BinToWord(ABin: String): Word
ABin - число в двоичном коде
Функция преобразует входное значение ABin строкового типа в десятичное значение.
Пример вызова:
ABin = '01001001' ,
результат = 73
Function
ConvertBinToHex(ABin: String):String;
ABin - число в двоичном коде
Преобразует входное значение строкового типа в шестнадцатиричное значение
Пример вызова:
ConvertBinToHex('01100100101');
Procedure
ExecuteApp(AFileName: String; AParam: String; mode:Boolean)
AFileName-имя исполняемого файла
AParam - параметры
mode
true - one instance
false - many instances
Позволяет запустить внешнее приложение AFileName, так же возможно указать дополнительные параметры AParam.
Пример вызова:
ExecuteApp(‘notepad.exe’,’c:\instruction1.txt’);
СКАЧАТЬ
ПРИМЕР
Function
FileExists (AFileName: String): Boolean
AFileName - имя файла
Функция проверки существования файла.
Пример вызова:
if FileExists("c:\receipt.txt") then fileEx:=true;
Function
StringToDateTime (ADateTime : string; ADateFormat: string): TDateTime
Преобразует входную строку ADateTime согласно с форматом в ADateFormat в переменную типа TDateTime
Параметры формата
yy = Год из 2-х последних цифр
yyyy = Год из 4-х цифр
m = Номер месяца без 0
mm = Номер месяца как 2 цифры
mmm = Месяц используя ShortDayNames (Янв)
mmmm = Месяц используя
d = Число без 0
dd = Число как 2 цифры
ddd = Число используя ShortDayNames (Воск)
dddd = Число используя
ddddd = Число в ShortDateFormat
dddddd = Число в LongDateFormat
h = Час без 0
hh = Час как 2 цифры
n = Минуты без 0
nn = Минуты как 2 цифры
s = Секунды без 0
ss = Секунды как 2 цифры
z = Миллисекунды без 0
zzz = Миллисекунды как 2 цифры
t = Используя ShortTimeFormat
tt = Используя LongTimeFormat
Примеры применения формата:
dd/mm/yy hh:mm:ss = 09/02/49 01:02:03
mmm = Фев
mmmm = Февраль
ddd = Вт
dddd = Вторник
ddddd = 09/02/2049
dddddd = 09 Февраль 2049
hhampm = 01AM
t = 01:02
tt = 01:02:03
dd/mm/yyyy = 09/02/2049
dd/mm/yy hh:mm:ss = 09-02-49 01_02_03
mmm = ФЕВ
mmmm = ФЕВРАЛЬ
ddd = ВТ
dddd = ВТОРНИК
ddddd = 09-ФЕВ-49
dddddd = ВТОРНИК 09 ФЕВРАЛЬ 1949
hhampm = 01утро
t = 01_02_03
tt = 01 _ 02 _ 03 . 004
dd/mm/yyyy = 09-02-1949
Подробнее:
http://www.delphibasics.ru/FormatDateTime.php
СКАЧАТЬ
ПРИМЕР


Раздел: Выполнение скрипта

  • Использование скриптов
  • Выполнение скрипта
← Пред
След →

Выполнение скрипта

Для тестового запуска скрипта на выполнение выберите команду Выполнить из меню Редактора скриптов:
После этого откроется окно выполнения скрипта. Окно выполнения отображает список имен каналов, используемых в работе скрипта, а также их текущих значений. Изменяемые значения каналов выделены зеленым цветом:

Выполнение команды записи в канал

1. Выполнение команды записи в канал
Произошла запись в активный канал с именем DI2.охлаждение значения False. Запись в канал происходит при вызове внутренней функции WriteValue. Если в тексте скрипта происходит запись в несуществующий канал, то данная команда игнорируется и не отображается в окне выполнения. Иконка изображает зеленый круг со стрелкой.

Выполнение команды чтения из канала

2. Выполнение команды чтения из канала
Произошло считывание данных из активного канала с именем Уровень мерник поз. 2 текущего значения. Пользователь может вводить данные в поле Значение и наблюдать результат работы скрипта в зависимости от исходных данных. Чтение из канала происходит при вызове внутренней функции ReadValue. Если в тексте скрипта происходит чтение из несуществующего канала, то данная команда игнорируется и не отображается в окне выполнения. Иконка изображает желтый круг со стрелкой.

Выполнение команды чтения из канала

3. Выполнение команды чтения из канала

Выполнение команды записи в канал

4. Выполнение команды записи в канал

Завершение выполнения скрипта

5. Завершение выполнения скрипта
Нажмите Стоп, для того чтобы завершить работу скрипта и закрыть окно выполнения.


Раздел: Компиляция скрипта

  • Использование скриптов
  • Компиляция скрипта
← Пред

Компиляция скрипта

Для того чтобы проверить скрипт на наличие синтаксических ошибок, запустите команду Компиляция из меню Редактора скриптов:
В результате компиляции в тексте скрипта могут быть обнаружены синтаксические ошибки и указаны номера ошибочных строк, или выдано сообщение об успешной компиляции:
Внимание! Компилятор не обнаруживает ошибки в именах каналов. Если имя канала задано неверно, или канал не является в данный момент активным (не отображается в правой панели Редактора скриптов), то обращение к нему игнорируется при запуске скрипта без выдачи предупреждающего сообщения.